7

Usually if you connect to a Remote Desktop Session Host running on a Windows Server 2008 R2 you will be prompted for your credentials and if they are valid you will be logged in to your session directly.

On one of our servers everyone who logs on with RDP sees the usual Windows Logon Screen (green/blue background with username/password) after already entering them in the Remote Desktop Client. So, users are not directly logged in, but have to enter their credentials twice. It is only the case for this server. The server also is a Remote Desktop Connection Broker.

Is this behavior caused by a wrong setting or do you know how to get rid of it?

3

We have that enabled on our of our machines through a GPO. Take a look at this setting: Windows Components/Remote Desktop Services/Remote Desktop Session Host/Security under Computer Configuration/Administrative Templates and look for this setting: Always prompt for password upon connection Enabled

2

I had a wrong setting enabled: Session Host Configuration -> Select the connection -> properties -> Credentials tab.

Here you can choose where to always ask for credentials or take the credentials provided by the client.

  • I'm running Windows 7, how does that actually look like? – Ion Todirel Jul 17 '13 at 4:59
-2

Check out his link. You can edit the RDP client connection to not display the first windows security logon box. http://chall32.blogspot.com.au/2012/04/fixing-remote-desktop-annoyances.html

  • He was asking how to provide credentials before connecting via RDP and why one server was different than the others and why it was prompting for authentication a second time. – Ryan Babchishin Oct 21 '15 at 6:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.