Updated: Narrowed in on issue and rephrased question.

I have two users who recently (last week or so) started having problems working on files on a network drive. Specifically opening, or copying the file locally. Both actions fail frequently while on the VPN, but work fine in the office. Nothing else is affected that I am observing. It is not a permissions issue. They have full permissions and this setup has been working for a long time (till now).

The files are small, 1-3MB even. I cannot reproduce this, except on one of the users machines, if I remote to it while they are on the VPN. Sure enough, it fails consistently, but occasionally works, when on VPN. I verified connectivity isn't an issue, by serving a large file via HTTPS on Apache on SERVER-A with no issues...but anything with the window fileshare and it croaks and times out with an error.

Error message #1 (in case of copying in windows explorer):

Network Error There is a problem accessing ....... Make sure you are connected to the network and try again.

Error message #2 ( in the case of trying to open a powerpoint):

Microsoft Office Powerpoint The path or file name for ... is invalid. Please check that the path and file name are correct.

At no time does VPN drop, and browsing of the fileshare is maintained...yet it's acting like the network share is dropping. I can maintain data transfer w/ that server (HTTPS) throughout while I get one of these error messages to occur. It seems like a network issue, but the only sign is failure to open or copy files from a fileshare.

Fileshares on other machines (from problem laptop on VPN) are not affected, which is strange. Now, it'd be great to just move everything somewhere and call it a day...but there are extensive sets of linked documents among these powerpoints and excel docs, so it's actually a major pain to move the documents to another location (and back, when fixed...)

I am going to investigate "auto-tuning" (http://support.microsoft.com/kb/934430) in the morning, but I am currently stumped. If it was that I would expect it to fail on other network shares...


  • Fileserver: SERVER-A, Windows Server 2003 R2
  • User machines: Windows 7 Professional
  • VPN server: SERVER-B, Windows Server 2003, PPTP using RRAS.
  • So first off - have you checked to make sure the users have the Modify permission on that folder? If they don't you can sometimes get temp file errors. Do the files work if copied somewhere else? Have you tried copying them elsewhere, verifying them, then deleting the originals, and moving the copies back? – Driftpeasant Dec 6 '11 at 23:08
  • Users have full permissions including modify. I haven't tried copy/verify/delete/move - I may give that a shot. – Joshua McKinnon Dec 6 '11 at 23:16
  • If copy/verify/delete/move works, you might have just gotten some corrupt(ish) files. Would probably be worth CHKDSKing the filesystem just to be sure. – Driftpeasant Dec 6 '11 at 23:18
  • I am having the similar problem over here, I can transfer any other file (doesn't matter larger or smaller), except the file I require. I am thinking to do a chkdsk, will let you know. – Dejan Janjušević Apr 11 '12 at 11:24
  • Could be a different issue in your case, @DejanJanjušević - in mine it ended up being windows 7 autotuning – Joshua McKinnon Apr 11 '12 at 16:12

I agree with driftpeasant, make sure users have modify permission on the folder, better still make sure they have full permissions....

I'd definitely check that the files are not in use elsewhere (perhaps backup software is accessing the file at the time). Check on the server to see if the files is/are open.

Also a good idea to copy the file from the server share to the local PC and see if they can open them from there.

Let us know.

  • Oooh, the intermittent nature could totally be the nightly backups ...Is there another way to check if the files are open on the server besides "net file" or "handle (sysinternals) ? – Joshua McKinnon Dec 6 '11 at 23:20
  • 1
    server 2003 right? if i remember correctly if you right click on MY COMPUTER and go to Manage - there is a OPEN FILES/SHARES area where you can control what files are open and you can close them here. – geek_joel Dec 6 '11 at 23:23
  • Nice - that is a lot easier to look at than "net file". – Joshua McKinnon Dec 6 '11 at 23:27
  • good luck buddy. hope you sort it. be sure to come back and let us know if you have any updates. – geek_joel Dec 6 '11 at 23:29
  • See my comment on the question above. The file is not open, the user has full permissions over the folder and all files, I can copy the file, move, rename, delete, create again, but it just doesn't want to transfer to these 2 specific clients. As a workaround I use TeamViewer to send the file to them. Which works. – Dejan Janjušević Apr 11 '12 at 11:33

What ended up resolving this issue for me (back in December) was disabling autotuning on the affected Windows 7 machines. KB934430 gives instructions on how to disable autotuning

From an elevated command prompt:

netsh interface tcp set global autotuninglevel=disabled

I have not seen any recurrence of this issue since - in 3+ months. Zero. Note this is only 1 or 2 laptops out of around 50 that ever saw this issue, so this was pretty isolated.

Not the answer you're looking for? Browse other questions tagged or ask your own question.