We're getting "HTTP Error 503. The service is unavailable.". Googling has provided lots of near hits, but none have worked so far.

The flow is: - confirm all app pools started - open browser to http://localhost, get 503 error - app pool is now stopped

The event log has 5 warnings of

"A listener channel for protocol 'http' in worker process 'nnnn' serving application pool 'DefaultAppPool' reported a listener channel failure. The data field contains the error number."

with the source WAS, details: ProtocolID: http FC2A0780 followed by 1 error

"Application pool 'DefaultAppPool' is being automatically disabled due to a series of failures in the process(es) serving that application pool."

Event ID 5002 Windows 2008 Enterprise, IIS7

All patches current as of 12/7/2011

Default Web Site, using DefaultAppPool

DefaultAppPool - tried Classic, Integrated modes, .NET 2 & 4, 32bit on and off, Identity of ApplicationPoolIdentity and an Administrator account, Ping enabled and not, Rapid-Fail enabled and not. Nothing in wwwroot except iisstart.htm, welcome.png and aspnet_client folder. Reinstalled IIS, .NET Framework.

Turning off Rapid-Fail simply resulted in never ending warnings and no logged error, but still got the 503 on the client.

The machine does not have RPC over HTTP or Sharepoint or Exchange installed, but does have SQL Server 2008 R2.

We've tried dozens of configurations, but all result in the same errors.

Any ideas?

  • Since when? Was this server ever working? – TristanK Dec 10 '11 at 21:39
  • @TristanK, I thought that the web server had worked but apparently not. We set up the machine, moved the databases over and got sidetracked. Upon our return we found the problem. As soon as I changed the machine name, it worked just like expected. – Alien Technology Dec 19 '11 at 16:06

Our cloud provider came up with the answer - I wish I could name them here.

The Windows server had a dot in the name like this: my.server which is not allowed on non-domain machines.

Windows never complained about the invalid machine name, nor did IIS, but it caused the listeners and thus the application pool to fail. Changed the machine name and all is well again.

Hopefully this will help someone else save some time.

  • Great to see that you found out what the problem is! Please mark this as your accepted answer :) – pauska Dec 13 '11 at 14:41

right click properties of application pool and check enable 32bit applications

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.