0

I've tried to setup AD authentication according to instructions found at this link , but it wasn't successful, AD authentication didn't work.
In cache.log, I've got:
squid_ldap_auth: WARNING, LDAP search error 'Operations error'

I've tried to manually authenticate direct from command line:

/usr/lib/squid/ldap_auth -R -b dc=central,dc=company,dc=local -D cn=BobanAdmin,cn=Users,dc=central,dc=company,dc=local -w password -f sAMAccountName=boban -h 192.168.0.13 -v 3

and there was no output, only prompt hanging...
DN and corresponding password are OK, and I'm successfully doing ldapsearch with that credentials. I've also tried to place quotes to many different places, but with no results.

What am I doing wrong?

  • Where you have put above "cn=Boban Admin," Is there a space in there, or is that just the way the line has rapped around? – jwbensley Dec 13 '11 at 12:20
  • It's a space there. – Boban P. Dec 13 '11 at 12:56
  • I see, well you can't have a space there in the middle of a bash command without escaping it – jwbensley Dec 13 '11 at 13:07
  • 1
    THERE'S NO ESCAPING BASH! RAWR! – Bart Silverstrim Dec 13 '11 at 13:23
  • I've tried it with Boban\ Admin, "Boban Admin", 'Boban Admin'... No success... – Boban P. Dec 13 '11 at 13:30
0

It is waiting for a username and password to be entered at the command line. I have to enter the username then a single space then the password and press enter. Now it returns a result...

root@ubuntu:~# /usr/lib/squid/ldap_auth -R -b "dc=central,dc=company,dc=local" -D "cn=BobanAdmin,cn=Users,dc=central,dc=company,dc=local" -w "password" -f sAMAccountName=%s -h 192.168.0.13
After this, it waits for a username and a password:
boban mypass
and finally returns:
OK

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.