I'm using an Amazon EC2 istance as developer and testing machine. Since i'm on windows i can't mount the virtual EBS volume for editing purposes. Too bad.

For this reason i've installed and configured vsftpd server to allow me quickly edit and upload PHP files from Windows to /var/www/html folder on the instance.

I've uncommented lines containing the word "root" in /etc/vsftpd/ftpuserss and /etc/vsftpd/user_list in order to allow root login with FileZilla.

My /ect/vsftpd/vsftpd.conf contains (among other):

pasv_address=<public ip addess>

I know maybe login as a root can be a security issue but i'm not master in security stack on linux. Feel free to post any security tip to solve my problem. By the way, i'm getting this error:

500 OOPS: cannot change directory:/root

It seems that vsftpd try to change the ftp root to /root (of course it doesn't exist), ignoring the local_root option.


No, No, NO, NOOO - that is entirely the wrong thing to do. You are sending your root password unencrypted across the internet. STOP !

If you really must use FTP then create a user account specifically for this. It would be much better if you created a user account to do this and then used scp or sftp and public keys (check out putty for windows).

  • Thanks for the answer. There is no root password by the way. I'm using putty with private an public key for server admin, but uploading many files (as they change) manually using putty is a pain. Any other solution is much appreciated. – user34295 Dec 14 '11 at 11:57
  • 1
    @Gremo: FileZilla supports sftp and ssh keys, just use that instead of ftp. – Janne Pikkarainen Dec 14 '11 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.