I have few system with ipv6 addresses. I want to forward request from one system to another. hence I kept the option

net.ipv6.conf.all.forwarding = 1

in sysctl.conf

but the request is not getting forwarded as it is doing in ipv4, its giving me the error in booting also. net.ipv6.conf.all.forwarding 1 is an unknown key

  • Can you set it with sysctl -w? – growse Dec 15 '11 at 20:33
  • What do you see if you do a grep IPV6 /boot/config-$(uname -r)? Where config-??? is the path to the kernel config file. – Zoredache Dec 15 '11 at 21:27

It is possible you don't have the ipv6 kernel module loaded on the system you're referring to. If you execute sysctl -a|grep ipv6 you will get a list of all available sysctl's referring specifically to ipv6. If that list is empty, that would lead me to believe ipv6 is not loaded.

If you do see the net.ipv6.conf.all.forwarding entry in that sysctl grep, then I would suggest copy-and-pasting the line from the output into sysctl.conf directly so as to be sure there aren't any incorrect characters added. Simply change the 0 to a 1 in the config if it shows as 0 (disabled.)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.