I've purchased two different used APC 2200 RM units, and both have entered into a mode where they execute a continual self-test: that is, they go on battery briefly, test, then the test comes back good, and life continues - until the next test a few minutes or seconds later.

The first one we received performed self-tests every so many minutes; the current one is doing self-tests about once every five seconds.

The UPSes didn't start this way immediately, but went on battery first, then drained all the way. This was the first indication something was wrong - whether the tests began then or not I'm not sure. Until that point, both were good. The first model went on battery initially because of powerloss in-house; the second went on battery for no discernable reason.

Once this occurred, the continual self-tests began. Because of the continual testing - and going on battery - the batteries drained rapidly. With the current UPS, there's not even enough time to get a charge of any kind; the previous UPS would whipsaw its way to 100% charge.

Both appear to have the same UPS firmware: 82.11.D.

Here is a report of the current UPS results (reported by Linux NUT) from the problem UPS:

battery.alarm.threshold: 0
battery.charge: 000.0
battery.charge.restart: 00
battery.date: 11/23/11
battery.packs: 000
battery.runtime: 0
battery.runtime.low: 120
battery.voltage: 48.04
battery.voltage.nominal: 048
driver.name: apcsmart
driver.parameter.pollinterval: 2
driver.parameter.port: /dev/ttyS0
driver.version: 2.2.2
driver.version.internal: 1.99.8
input.frequency: 60.00
input.quality: FF
input.sensitivity: M
input.transfer.high: 132
input.transfer.low: 103
input.transfer.reason: S
input.voltage: 123.5
input.voltage.maximum: 123.5
input.voltage.minimum: 122.8
output.voltage: 000.0
output.voltage.nominal: 115
ups.delay.shutdown: 020
ups.delay.start: 000
ups.firmware: 82.11.D
ups.id: UPS A3
ups.load: 000.0
ups.mfr: APC
ups.mfr.date: 11/23/11
ups.model: SMART-UPS 2200 RM
ups.serial: WS0104012242
ups.status: LB
ups.temperature: 029.7
ups.test.interval: 1209600
ups.test.result: NO

The batteries were the same in both. We tried switching outlets, with no difference. Also tried switching the sensitivity downwards with no change.

Can some kind soul help? Would the batteries do this?

PS: It sounds like someone else has experienced this problem; at least, that is what it sounds like from the ServerFault question: Smart UPS 2200 question.

UPDATE: Found this forum article about something very similar that happened to an APC 3000 RM model; in that case, the monitoring cable turned out to be the culprit. The model I have did not come with a cable and I'm using an external Smart Cable made by APC - the black ones, supposedly the 940-0024E variant if memory serves. Removed cable and am waiting to see what happens.

  • Have you unplugged everything from them, unplugged them from the outlet, then turned them fully off? We had to do this when one of them stopped responding over USB. – KJ-SRS Dec 15 '11 at 23:17
  • Report it to APC support? – Tom O'Connor Dec 15 '11 at 23:27
  • This is a used model; I've already had the first one sent back under an RMA and got this new one. Trying to figure out what happened. – Mei Dec 15 '11 at 23:57
  • Why would you buy a used UPS? You have no warranty or recourse in the event that you have problems... – ewwhite Dec 16 '11 at 8:01
  • THe used UPS is under warranty and we have already replaced one via the seller's return policy. – Mei Dec 19 '11 at 14:16

Your manufacturer date is very recent, according to the information you've posted. I wouldn't trust my equipment to a malfunctioning device. I'd simply call APC Support and warranty the misbehaving unit.

  • This is a used model and there's no way it was manufactured less than a month ago. Otherwise that would be a good recommendation. – Mei Dec 15 '11 at 22:59

I discovered a forum post on the APC forums that briefly mentioned this issue; it turns out the serial monitoring cable ("Smart Signaling" cable) is to blame. For some reason, it must be bad.

The cable seemed to work fine from a monitoring standpoint; expected values were being returned. When I pulled the monitoring cable out from the UPS (an APC 2200 RM) the endless self-test cycle stopped. When I moved the cable from the used UPS we had purchased to an older model (an APC 1500) the APC 1500 started entering into a continual self-test, just like the recently purchased UPS had been. When I moved the cable back to the newly purchased UPS, it again began to self-test.

Replacing the cable with a different cable that had been working resolved the issue entirely.

As I bought the cables at the same time as the UPSes and from the same vendor, they will send me a new cable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.