I have been given two Eee PC 100HA to manage for some people, they are both running the same hardware and XP home but one is having some strange problems with logging on.

The main problem is that it hangs at the login screen for ages and sometimes never gets to the desktop. The strange thing is it only seems to do it after the computer has been cold started, but it won't do it if the computer has been restarted.

I have made two logs of the start up with process monitor but every time the logger is attached the computer will log in fine. I have also set the computer to blue screen and create a crash dump when you press ctrl scroll twice but when I do it at the hung login it just sits at a black screen and I don't get a crash dump, I have turned off the auto system restart on failure option also.

I can usually fix most computer start up and shutdown problems but this one has got me stuffed.

Has anyone had the same problems before, or can recommend something that I can try?


  • I assume you've tried safe mode?
    – Mark
    May 6, 2009 at 2:24
  • 1
    There have been several anwers to your question so far, but most of them ask more questions in return as well. If you want a good answer to your question, you will probably want to give some feedback to our questions so that we can help you solve your problem. Thanks! May 6, 2009 at 8:12
  • I would love to give some feedback, but I haven't been able to get around to trying anything yet. I will try everyones suggestions as soon as I get a chance and leave some feedback.
    – Nathan W
    May 6, 2009 at 9:25

8 Answers 8


The main problem is that it hangs at the login screen for ages and sometimes never gets to the desktop.

If this is before you login, DNS is likely to blame.

If it's after you login, I'd guess a profile issue. Create a new user and profile and try with that.

Some additional things to try:

  • Disconnect from network (wireless and wired). This will isolate any calls to a non-existent server, like for a mapped drive, GPOs, or something.
  • Autoruns to disable all startup items.
  • Disk defrag and Scandisk for bad disk errors. They should also be reported in EventViewer.
  • Wireshark on another PC on a hub to watch login traffic.
  • turns out it was something with the profile, I made a new one and it didn't have the problem. So I'm going to try and compare profile settings and see if I can find what caused it.
    – Nathan W
    May 12, 2009 at 8:37

Does Caps Lock work (in terms of changing the caps indicator) when it's hung? If not, that would suggest it's completely borked by that point rather than just a process taking forever to get properly started.

If that works, does Ctrl-Shift-Esc bring up task manager? That could be useful to show any processes taking a long time, if the logger isn't helping you.

  • I use Caps Lock all the time for just such a test. That may, however, be the only real use for Caps Lock... May 10, 2009 at 12:22

You can try enabling verbose startup status messages in the registry. It might help you determine what causes the hang during logon.

Go To:


To enable verbose status messages create a new DWORD value called "verbosestatus" and set it to "1".

An additional value called "DisableStatusMessages" forces status messages to be disabled, make sure this value does not exist or is set to "0".

Additionally, I recommend that you download Autoruns and use it to determine what loads up in the "Logon" tab.


Have you tried booting on safe mode (verbose)? 9 out of 10 you will see where it is getting "stuck" on the black safe boot screen. Try both, with and without network, and take action accondingly.

In an extreme case, and before pointing fingers to hardware problems, I would make sure it is running the latest BIOS firmware, re-install Windows, make sure to install the proper drivers and see if the problem continues. If it does, you could either choose to run hardware diagnostics or open a support ticket with the machine manufacturer.


I've seen this when there were mounted drives to a network that doesn't exist anymore or isn't available. Disconnecting the drives fixed the problem. But beside that I would guess it's a network config issue (trying to authenticate to a domain that doesn't exist maybe because of DNS issues, etc).

  • Had such an issue recently, too. In my case even regular Windows Explorer was heavily affected.
    – mark
    May 8, 2009 at 6:44

One other option is to run MSConfig (start -> run -> msconfig) and deselect all un-necessary services / startup programs and then re-enable them.

also, you could check the registry folder for the RunOnce to see if on shutting down if anything is being added to this.

finally does this happen if you create a brand new user and log in as them? If so then it could be a corrupt profile or other antagonist.


This could either be a service / app issue, or a hardware / driver problem.

I'd try the following:

  • does this problem occur when booting into safe mode?
  • if not, disconnect all peripherals except for a standard keyboard and mouse, and try again. Does it occur now?
  • if not, you know that it is piece of hardware or its corresponding driver
  • if it does continue to happen, use msconfig and disable all items under 'Startup' and all non-Microsoft items under 'Services'. Divide and conquer.

The only similar experience I've had with a netbook was resolved by disabling hibernation entirely. It sounds like a glib answer, but I haven't had the issue since, and I've had no motivation to re-enable it. Is it possible that your user's method of shutting down is to close the screen?

If there's the possibility of a hardware issue, you could swap hard drives and see if the issue migrates to the other user.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .