I am working on an arch linux machine with ethernet interface eth1. I have created interface eth1:0 using ifconfig and given it a dummy hw address (00:01:02:03:04:05). When I send a UDP packet to a server application running on a remote server machine, I get back the right response. But then I see ICMP Destination Unreachable going out from the eth1:0 interface ip address. How can I mute this ICMP message? I have tried different mac addresses, setup arp cache on both client and server machines without success.

Appreciate any help and thanks in advance.

  • 1
    I wonder that you set an hw address to the additional interface. Are you aware, that the mac adresses started with 00:01:02 used by 3COM? (standards.ieee.org/develop/regauth/oui/oui.txt) Why you need an additional mac address? To answer your question: Don't mute icmp responses but fix the problem or explain what you try to acomplish. – f4m8 Dec 20 '11 at 10:33
  • As I said I have also tried to use the interface hw address for alias interface but without success. Appreciate any help in fixing this. – John Qualis Dec 20 '11 at 10:38
  • What is your problem? – mailq Dec 20 '11 at 10:45
  • I would like to get rid of the ICMP messages. – John Qualis Dec 20 '11 at 10:57
  • Then open the destination. – mailq Dec 20 '11 at 11:41

I'm sort of in the same boat with others here. Its better to track down and fix the root cause. To open the port isn't it a case of simply writing the correct firewall/IPTables rule? If you just want to blow ICMP outgoing, this thread should give you a good idea,

Why not block ICMP?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.