When I try to connect to a couple of our ESXi servers with my vSphere client I get the following error message:

"vSphere Client could not connect to "IP Address". An unknown connection error occurred. (The client could not send a complete request to the server. (The underlying connection was closed: An unexpected error occurred on a send.))

I'm thinking this may have something to do with a version incompatibility but I'm not sure. Can somebody shed some light?

  • Well are you using a VSClient that's up to the same level as the host you're trying to work on and if the host is lower than the client version have you installed that version too? – Chopper3 Dec 20 '11 at 19:19

This error troubled me for quite a while, and since this thread is still the first google result, here is my solution.

It is quite simple actually, just "Restart the Management agents". As mentioned by VMWare knowledge base all you have to do is run:

/etc/init.d/hostd restart
/etc/init.d/vpxa restart

from shell.

  • Worked perfectly! – Saif Jul 2 '15 at 8:00
  • For me only /etc/init.d/hostd restart solved the issue – Lisandro Dec 9 '15 at 18:37

Test the network by pointing your web browser at the address of the server. It should give you a web page and a link to download the client and a link to login to the Web UI.

If the page displays correctly then login to the web ui to test your logon/pw

  • Looks like there is a bigger problem. Just talked to another guy here who told me there is a problem where the web interface/client stops working periodically (however, the VMs stay up) and the machine has to be rebooted. Thanks for leading me to the next step! – Windows Ninja Dec 20 '11 at 19:28

If vSphere client is installed to Windows XP or 2003 then it could be a known problem with ciphers. A solution described here and here boils down to

  1. Enabling SSH access from ESXi console:
    F2 → Troubleshooting Options → Enable SSH

  2. From SSH session edit /etc/vmware/rhttpproxy/config.xml and insert <cipherList>ALL</cipherList> into /config/vmacore/ssl section.

  3. /etc/init.d/rhttpproxy restart

This helped me to access _VMware ESXi 6.0.0 from vSphere Client 6.0.0 on Windows XP.


I realize I'm coming back to this question much later than when it was posted, but I had forgotten that I posted this question and when I saw it, I wanted to share the solution with others.

It turned out the problem was my monitoring solution of all things. I had a check setup for the system to check the https page for the host every 5 minutes which for some reason would eventually cause the system to respond to everything, to the point where vSphere clients couldn't even connect anymore.

I disabled this check (relying instead on pings) and this problem hasn't returned for almost a year now.

I'm guessing there is a security setting somewhere under the hood of ESXi 4.x that tells the system to stop responding after a specified number of requests, but I wasn't able to locate that.

When the issue would start occurring, the VMs would stay up, however you couldn't connect to anything at the hypervisor level until completely rebooting the system (even restarting the management services would not fix it).

I tried updating to the most recent versions of ESXi but that did not resolve the issue.

  • What monitoring software were you using? – Jagger Dec 3 '12 at 22:24
  • This was at a previous job but we were using ServersAlive. – Windows Ninja Jan 13 '14 at 12:51

Start VMware Services
Just ensure that the 1-VMware VirtualCenter Management Webservices and 2-VMware VirtualCenter Server services are both 'Started' and you are good to go.

  • The person who originally posted the question has already posted what the answer/problem turned out to be, and this wasn't it. – Rob Moir Jan 22 '13 at 8:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.