Since this site is a Q&A for system administrators and desktop support professionals I'd decided to post my question here. Not sure if this is the best stackexchange website for this.

We have an HP Color Laserjet 4700n of course out of warranty. And we have an 49.4CF2 Service error. According to several sources online, this is firmware related.

When I switch of the printer and switch it back on, it gives this error again. I have tried to give it a cold reset. But that didn't work either. I have downloaded both firmware downloads from hp.com first one has an application which transfers the firmware to the printer, but after about 5% the printer switches again to 49.4CF2 Service error. I also tried the second firmware. So I used filezilla to transfer the .rfu file. The start of the transfer looked good. But again, after about 5% there was a lost connection.

I do not know what else I can try to resolve this error.

p.s. ping-ing the printer works. but stops when the error occurs. same for webinterface of the network printer.


HP printer display

EDIT: as Jan Marek and Ezio Zanghellini said: the firmware is still not updated. Seems impossible!

  • 1
    I'd say you posted this in exactly the right place. – Tom O'Connor Dec 21 '11 at 13:29
  • 1
    I have a similar problem with a HP CLJ 4700: when I try to upgrade the firmware I get the 49.4CF2 error. I have tried the following suggested solutions: change of IP address, change of formatter, change of RAM SODIMM, upgrade of the jetDirect firmware alone, use of USB cable, use of net cable. None works. The only thing left I can think of is the flash memory. I could upgrade the firmware of the jetDirect alone (getting no error), but I still get the error when I try to upgrade the firmware of the printer. When using the hash option with FTP PUT, the communication stops after about 2MB or 4 MB – user106559 Jan 10 '12 at 14:26
  • 2
    Note that the HP firmware URL is no longer valid . . . try ftp.hp.com/pub/networking/software/pfirmware instead . . . – user196787 Oct 30 '13 at 18:42

Seems that it is solved!

Since I am no expert in the kitchen with ovens etc. I had decided to skip Pauska's solution (sorry, nothing personal)

I disconnected the network cable. The printer boots fine then. But I can only print by network. So I reconnected it and changed the static IP address from .190 to .192 (on the end) and reconfigured a lot of pc's to use the new (lan) ip.

And the service error is gone. I still have no idea what might have caused this. Maybe a PC in the LAN keeps sending wrong stuff to the IP address?

  • 1
    I recommend you to upgrade firmware though... – Jan Marek Dec 21 '11 at 19:41
  • Hi Jan, I have the feeling that the error will occur again and that the upgrade is impossible. the only reason that i wanted to upgrade the firmware was because of the returning service error – JP Hellemons Dec 22 '11 at 7:55

I've heard about people baking the formatter (yes, in a oven) to fix bad soldering on the HP P2015.. It's a crazy idea, but perhaps it would work as a last resort.

See this or this video (warning, loud music).


Remove the DIMM RAM... Remove EIO devices... Check that the formatter is secured... See if it starts working properly... If so, put the stuff back in until the failure reappear.

If all fails... It could be a faulty formatter, but this is very unusual.

  • The strange thing is that this error started yesterday. We have the printer for several years and never had this. But will try to remove the formatter and re-insert the RAM – JP Hellemons Dec 21 '11 at 12:06

You can try detect, where is problem with this device according answers on this forum (remove a NIC and try to start printer and wait, if error occur, if not, you can add NIC w/o plug network connection and try to start printer and wait, if this error occur, you can try empty your queue and after that do reset of your printer, or empty your queue and then try to upgrade firmware)...

  • can't upgrade. during upgrading process loses connection and get the error on the display of the printer. also tried a cold reset. same thing. during upgrade i get a service error – JP Hellemons Dec 21 '11 at 11:23
  • Have you actually read the question? Or did you stop after reading the error code? – Sven Dec 21 '11 at 11:24
  • I'm so sorry about that. I've tried to change my answer to fit better @JPHellemons needs... – Jan Marek Dec 21 '11 at 11:39
  • No problem, have not tried to start the printer without network connection. But I think that it will be ok then and that the error will occur after a small task or at several percent of a big task (like firmware update) – JP Hellemons Dec 21 '11 at 12:15

I'm responding to the additional folks, and the original post, about not upgrading the firmware. We had a spare HP Color LaserJet 4700 in a box we just took out. Tried to upgrade using the latest fw (2012) and received the same 49 service error. On another forum, I found the answer: HP has an ftp accessible repository for their old printer firmware: ftp://www.hp.com/pub/networking/software/pfirmware/

As per someone else's hard work in determining which fw to use: we had 20051204 46.029.3 got 20091125 46.120.4 from the repository Used Web JetAdmin to import the fw, then send it to the printer. From there, already had the 2012 fw, so upgraded the printer again, and now it's working fine!

BTW, the other forum where I found this at is: http://h30499.www3.hp.com/t5/Printers-LaserJet/CLJ-4700-49-4CF2-error/td-p/5293729

  • ok, but i could not upgrade through web interface and also not by a manual upload with ftp – JP Hellemons May 18 '12 at 7:21

I managed to find a firmware that overcomes the barriers of what HP has introduced for the signature. You can upload lj4700fw_46_130_5 and then the latest firmware.




My first step was the installation of

  1. lj4700fw_46_130_5, followed by error BAD LUCID XX, which I do not know what it meant. After switching off and on again to display the banner RESEND UPGRADE.

  2. I've already uploaded version lj4700fw_180.xx (I think it was unnecessary).

  3. latest firmware. Each firmware lasted about 15 minutes, you have to be patient :)

All through the FTP protocol.

  • I've looked everywhere I can for that firmware. It does appear to have been removed from the HP FTP site. I suspect this is because it's now totally End of Life, and End of Support. – Tom O'Connor Dec 9 '13 at 13:46
  • If you're having further issues, stop wasting your time on it (your time isn't free [especially to your employer]), and buy a more up-to-date printer. – Tom O'Connor Dec 9 '13 at 13:47

protected by Mark Henderson Dec 19 '13 at 0:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.