I have one particular Hyper-V guest, one of 5 on this particular Hyper-V host, that can't seem to make any outgoing network connections. The guest is running Windows Server 2008 R2 SP1 and uses IIS 7.7 with the URL Rewrite module and Application Request Routing, so that the IIS server acts as a front end reverse proxy for several other apache-based web servers. This all works fine, incoming requests to the server are handled correctly and the responses from all of the services get returned correctly.

The problem is that nothing on that server can make an outgoing connection. So for example, I can't use IE9 to browse external web sites, auto-updates fail, the back end servers can't 'phone home' to check for updates, things like Hamachi VPN can't communicate with the Hamachi servers and so on. It seems like the server can't generate any outbound connections at all.

Other guest VMs on the same host have no problems. I've compared the NETSH DUMP from two guests and, apart from IP addresses, they're identical.

I'm thinking this must be tied in with the Application Request Routing stuff somehow, but I can't think how or why. I'd appreciate any advice on investigating this issue further.

  • Does anything change if you disable the firewall? – Richard Dec 24 '11 at 9:42
  • I'm alaways reluctant to turn of security features as a troubleshooting step, but given that there is at least one other firewall between the VM and the Internet, I guess it is worth a try. – Tim Long Dec 25 '11 at 2:31

Turning off the firewall made no difference. Eventually, I fixed the problem by taking the following steps:

  • Shut down the VM
  • removed the virtual NICs using the Hyper-V management console
  • started the VM
  • cleaned up some old phantom adapters
  • shut down the VM
  • re-added the virtual NICs in the management console
  • Started teh VM and configured its networking.

Everything works now. Not sure if it was a phantom adapter or some misconfiguration.

|improve this answer|||||
  • Could you mark that as an answer? – Daniel Mar 28 '16 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.