I've just been doing some regular maintenance on my Solaris 11 box. I issued a pkg update command to be told that I needed to update pkg. This I did, and rebooted into solaris-1.

I then issued another pkg update, and it downloaded and installed about 600MB worth of packages. However, on rebooting into solaris-2, it fails to boot stating:

SunOS Release 5.11 Version 11.0 64-bit
Copyright (c) 1983, 2011, Oracle and/or its affiliates. All rights reserved.
NMI received
WARNING: intel_iommu0: generated a fault event when translating DMA read
         on address 0x40000 for PCI(9, 0, 0), the reason is:
         The Read field in a page-table entry is Clear when DMA read
WARNING: cpqary30: domid 3 pte: 0(paddr 0)
WARNING: CPQary3 : Smart Array P212 Controller HBA firmware Locked !!!

WARNING: CPQary3 :Please reboot the system

It then coredumps and reboots.

I've tried adding intel-iommu=no to the existing grub -B arguments, to read:

-B intel-iommu=no,$ZFS-ARGS

but, this doesn't make any difference.

Hardware is an HP X1600 with a Smart Array P212 controller.

What's going on?

scanpci -v shows PCI(9,0,0) as:

pci bus 0x0009 cardnum 0x00 function 0x00: vendor 0x103c device 0x323a
 Hewlett-Packard Company Smart Array G6 controllers
 CardVendor 0x103c card 0x3241 (Hewlett-Packard Company, Smart Array P212)
  STATUS    0x0010  COMMAND 0x0047
  CLASS     0x01 0x04 0x00  REVISION 0x01
  BIST      0x00  HEADER 0x00  LATENCY 0x00  CACHE 0x10
  BASE0     0xfbc00000 SIZE 4194304  MEM
  BASE2     0xfbbf0000 SIZE 4096  MEM
  BASE4     0x00005000 SIZE 256  I/O
  BASEROM   0x00000000  addr 0x00000000
  MAX_LAT   0x00  MIN_GNT 0x00  INT_PIN 0x01  INT_LINE 0x05

I appear to have solved this.

I disabled Intel VT-d and Intel Virtualization in the BIOS, and all seems to work now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.