I'd like to call something like:

sudo yum install apt

to enable me to use apt-get as well as yum for installation.

However this doesn't work. I get the following back:

Loaded plugins: fastestmirror, priorities, security, update-motd
Loading mirror speeds from cached hostfile
 * amzn-main: packages.eu-west-1.amazonaws.com
 * amzn-updates: packages.eu-west-1.amazonaws.com
Setting up Install Process
No package apt available.
Error: Nothing to do

It looks like it requires making the default Amazon EC2 instance aware of repositories.

In a nutshell: how I can simply enable use of apt-get instead of just yum?

4 Answers 4


apt-get is a Debian tool. yum (and rpm) are Red Hat tools. They are not compatible; neither are the packages which they install.

If you want to use apt-get, use a Debian (or Ubuntu) image instead of Red Hat (or CentOS, or whatnot).


YUM is the defacto RPM package management on RHEL (Centos) systems, and it works quite well once you get the hang of it- my very best suggestion is to familiarize yourself with YUM or use Debian...

That being said you can try to install one of these RepoForge packages (or set your /etc/yum/repos.d :D ) , then retry sudo yum install apt



It sounds like @duskwuff is probably correct: you're expecting a Debian (or Debian-based, like Ubuntu) operating system. Yum is used in Red Hat-based operating systems (like Fedora, CentOS, Yellow Dog, Scientific, whatever).

They serve about the same purposes: for the most common cases:

   apt-cache search $FOO         ==   yum search $FOO   ||  yum search all $FOO
   apt-get install $FOO          ==   yum install $FOO
   apt-get update                ==   (not needed, happens on every hit)
   apt-get upgrade               ==   yum update

However, apt is available on stock Fedora. If you are running Fedora —

     $ cat /etc/fedora-release 
    Fedora release 15 (Lovelock)

Then you can add in the stock Fedora repositories by copying them from the /etc/yum.repos.d on another machine running the same OS. (Check for the files already being there, but disabled: /etc/yum.repos.d/ should have a number of .repo files, that might be disabled, for the stock Fedora repositories…)

Personally, I'd recommend against using RPMforge unless you're familiar with the risks … I've run into problems merging their packages with the stock OS. RPMfusion, however, has generally proven to be “safe.”


please go set a new rule in your (security group). select the security group ID your using "see the VPC" as well and click on Actioins. from there select Edit inbound rules and then select Anywhere under the sources field.

hope this solves the problem.

  • The OP's issue had nothing to do with network security rules.
    – user15323
    Nov 9, 2017 at 7:29
  • @duskwuff i had same issue and that fixed for me. he was asking this:"In a nutshell: how I can simply enable use of apt-get instead of just yum" i was not able to get apt-get unless i changed the rule.
    – Hadi
    Nov 9, 2017 at 21:03
  • Then you must have already been using a Debian or Ubuntu instance, and never had access to yum.
    – user15323
    Nov 9, 2017 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.