Dell doesn't "officially" support QLogic HBAs in their cheaper servers like R210 or R310. They support it with R410 upwards. But "official support" is a dubious concept anyway, at least for real men running Debian etc. ;-)

The qlogic HBA worked absolutely fine on the R210 hardware and we have certified it ourselfes. But with the successor, the R210 II, it doesn't: The system just doesn't boot. The BMC log states:

Severitiy: Cirtical
Date and Time: System Boot
POST Err: Post sensor, Timer refresh failed.

The LED diagnostics show 2 and 3, but LED 1 and 4 are not lit. An error led blinks.

Taking the qlogic hba out makes the system boot again. All firmware updates have been tried, also different HBAs from different manufacturing times.

This question is not really about what Dell officially support etc., but I'd rather love to hear from people who know how to diagnose this: What can be done if a PCI Express cards stops a server from booting? Is there any diagnostics port where one can see what's happening besides the BMC log? Did anybody successfully resolve such an issue with e.g. a poweredge server?

Are there any other experiences with the R210 II where it is more picky about extension cards?

Any guy from Dell knowing how to bypass Dells product policy?


  • 1
    Don't really have a solution, all i can say it's a weird post error as the timer refresh error is usually a RAM issue... the LED 2&3 indicates a hard drive failure... so doesn't make sense. The other diag you can run is the embedded diagnostics (by pressing F10 upon boot)
    – Cold T
    Dec 29, 2011 at 10:39
  • 1
    And that HBA still works in a R210 I? Or is it just broken? BTW - if I would need to run without support I would go for Emulex.
    – Nils
    Dec 29, 2011 at 21:35
  • 1
    Are you booting to the HBA? If not, it's electrical in nature most likely.
    – Dave P
    Dec 29, 2011 at 21:45
  • No, I'm not booting from HBA. I wish that feature could be ripped out of QLogic together with the option rom/Bios of QLogic.
    – Christian
    Jan 2, 2012 at 9:43

2 Answers 2


Had to chime in on this with a solution that is more viable and easier than any I've seen thus far.

As I had the same issue in just installing the HBA after install the OS (Windows 2008 R2); experiencing the same startup issue with light diagnostic indicators 2 and 3 illuminated. The Dell Owners manual said this is a harddrive missing error, although I have a SATA drive attached and bootable.

I found the BIOS level was ~version 1.3.x.x... Thus I downloaded the newer BIOS of version 2.3.2.x and this resolved the issue.


As I understand it, booting from any HBA, be it the built in SATA ports to an Infiniband adapter, requires BIOS support (or in the case of the R210, UEFI support). A lock like you're seeing is the result of a collision in the UEFI space that's preventing existing storage from being seen.

One possible method to get around this is to install the card in another, working server. In the qLogic BIOS, turn off and disable boot-from-san and any option-rom options that may be lurking in there. These settings are stored on the HBA itself, so when you put it back into the R210 II the settings should follow. It may work then.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.