We run command line program in automation process on Windows 2008 and sometimes when closing it Windows 2008 show dialog "this program has stopped working" with Close button. How to completely disable it? I've tried turning off error reporting for all users but that doesn't change a thing.


I have found how completely disable WerFault.exe (Windows Error Reporting). These registry keys should be added

[HKEY_CURRENT_USER\Software\Microsoft\Windows\Windows Error Reporting]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Windows Error Reporting]

I am also attaching fully working registry file http://www.filejumbo.com/Download/B6A1CD7B9A221BB8

I would like to add many instructions which I found on Internet about disabling WerFault didn't worked in my situation, these include:

  1. Disabling "Windows Error Reporting Service"
  2. Editing "Windows Error Reporting" Policies in Local Group Policy Editor
  3. Disabling ""Windows Error Reporting" from control panel.

This Microsoft article shows you go to HKLM\Software\Microsoft\Windows\Windows Error Reporting and add a DWORD key called DontShowUI with a value of 1.

  • I still get Windows Error Reporting dialog with one close button. In my Windows Server 2008 registry HKLM\Software\Microsoft\Windows\Windows Error Reporting I have such keys DontShowUI = 1 and Disabled = 1 (and several others). – Tomas Jan 4 '12 at 7:17
  • Agreed - this reg key only turns off the UI for the error reporting, not the UI for actually notifying of the error in the first place. – growse Jan 6 '12 at 14:12

Rename WerFault.exe file in Windows directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.