A few days ago I found I can no longer create symlinks from Ubuntu in any directories that are shared with the OS X host.

ln: creating symbolic link `foo': Read-only file system

I'm able to create symlinks in non-shared folders and on OS X directly. I've also tried running disk repair, but no errors were found.


  • OS X 10.6.6
  • Ubuntu server 11.04
  • Virtualbox 4.1.8

closed as off topic by MDMarra, Michael Hampton, Scott Pack, voretaq7 Oct 5 '12 at 17:23

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here. If this question can be reworded to fit the rules in the help center, please edit the question.


Another workaround is to run the following command on your host:

VBoxManage setextradata VM_NAME VBoxInternal2/SharedFoldersEnableSymlinksCreate/SHARE_NAME 1

Or on Windows

VBoxManage.exe setextradata VM_NAME VBoxInternal2/SharedFoldersEnableSymlinksCreate/SHARE_NAME 1

where VM_NAME is the name of your virtual machine (e.g Ubuntu) and SHARE_NAME the name of your shared directory (without the "sf_" prefix).

This will re-enable the previous symlink friendly behavior.

Note: On Windows, always restart the Virtual Machine AND VirtualBox GUI.

  • How do you run that on a Windows host? – Chris Pratt May 2 '12 at 18:40
  • 1
    @Chris, VBoxManage is located in the Program Files directory (e.g. C:\Program Files\Oracle\VirtualBox\VBoxManage.exe). That said, I have not been able to get the solution to work for me yet when hosting on windows (details at virtualbox.org/ticket/10085#comment:16). – studgeek May 16 '12 at 4:08
  • @schisamo can you confirm this actually worked for you on Windows/NTFS? I (and others) still get "read only file-system" as I describe in the ticket at virtualbox.org/ticket/10085#comment:16. – studgeek Jun 14 '12 at 20:19
  • Couldn't get this to work with a Windows host – OlliM Jul 2 '12 at 12:39
  • 2
    This solution helped. The only thing you mustn't forget is to change SHARE_NAME to your actual share name – n1313 Oct 3 '12 at 16:28

On a windows host - run the virtual machine instance as an Administrator. I found this solved the problem.

-- I tried @schisamo's suggestion first - it may be necessary to do both. Apologies I would have added this as a comment but I'm so rep-poor I can't even comment ;-)


This appears to be a bug in VirtualBox 4.1.8. Some people report that downgrading to 4.1.6 resolves the issue. See https://www.virtualbox.org/ticket/10085

Not the answer you're looking for? Browse other questions tagged or ask your own question.