There's a virtual machine with Windows Server 2008 R2 installed. There are two NICs connected to it: PROD & BUP. The BUP interface is configured without default gateway. After adding static route with /p switch, it appears in routing table but traffic still goes through default gateway if you run tracert.

I've even tried to add IF parameter but the same thing, doesn't work. Machine hasn't been restarted yet.

What is interesting, there is another Windows Server 2008 R2 machine with such static route and BUP interface's IP-address in the same subnet and everything works perfectly.

1 Answer 1


I've seen this on Windows 2008 R2 a few times, where the route add /p simply doesn't stick. Use netsh with the ipv4 context switch instead.

Let's say your local backup destination net is Use netsh like this:

netsh ipv4 add persistentroute "BUP"

Where: is the destination net, is the destination subnet mask and "BUP" is the name of the interface you wish to use

  • Tried this, but it didn't work either. Wanna try deleting all static routes, restarting machine & then re-adding routes once again. Anyway, thx for good suggestion. Jan 3, 2012 at 10:12
  • Got one more idea - to disable PROD lan, but haven't done that yet. Jan 5, 2012 at 9:14
  • I'd rather try to remove the route, disabling and then enabling the backup interface and then adding it again Jan 5, 2012 at 9:28
  • This has been already done several times, no success. Jan 11, 2012 at 10:11
  • Even more: I've tried deleting virtual NIC and then re-adding it - still doesn't work :(. Jan 12, 2012 at 9:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.