I have installed Ubuntu 10.04 (64 bit desktop version) on VMWare player over Windows 7 host (64 bit). I am unable to access network. apt-get fails and I am unable to browse the internet. I tried re-installing VMWare tools..it didn't help. I am new to Virtualization and networking. Can someone please help me out?

Output of ifconfig from inside Ubuntu:

aadith@ubuntu:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0c:29:c6:56:b7  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::20c:29ff:fec6:56b7/64 Scope:Link
          RX packets:386 errors:0 dropped:0 overruns:0 frame:0
          TX packets:534 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:36482 (36.4 KB)  TX bytes:58569 (58.5 KB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:380 errors:0 dropped:0 overruns:0 frame:0
          TX packets:380 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:29248 (29.2 KB)  TX bytes:29248 (29.2 KB)

  • Is the guest obtaining an IP? While inside debian type ifconfig and post the output. – Tim Jan 3 '12 at 16:23
  • are you behind a proxy ? do you use nat or bridged networking on you virtual machine ? – m0ntassar Jan 3 '12 at 18:04
  • @Tim updating the question with ifconfig I got from inside Ubuntu: – Aadith Jan 6 '12 at 8:21
  • @m0ntassar i tried both bridged and nat..neither worked – Aadith Jan 6 '12 at 8:24
  • @Aadith when you switch to bridged you may have to configure the network manually if there is not a DHCP server on your "real" network that the host is attached to. After switching to bridged mode and rebooting what is the output of ifconfig? – Tim Jan 6 '12 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.