1

my ssh has started to refuse users from out of the blue. I started to connect via Putty as root, me and other users.

login as: root
root@31.XX.XX.XXX's password:
Access denied

What could be wrong? I didn't change anything.

  • Could you check your server logs ? You will find a more interesting information for debuging your problem – Dom Jan 4 '12 at 8:41
  • Can you post the output of ssh -v server_ip? – Khaled Jan 4 '12 at 8:47
  • 1
    Thank you guys for the advices. I find out, that the root isn't in allowed groups. So, solved by editing /etc/ssh/sshd_config! – Ginnyous Jan 4 '12 at 9:02
  • 3
    @Ginnyous Be careful with root login enabled - it's one less barrier for an attacker to overcome. – Shane Madden Jan 4 '12 at 22:39
2

By default root user is not allowed to login in SSH remote connection. Anyway I recommend you using a normal user to work, not root. You can always use sudo if you need it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.