What I want to do is the following:

I have a Windows Server 2008 R2 (DC) with a running Active Directory. I added the role Windows Deployment Services and installed both Windows® Automated Installation Kit (AIK) for Windows® 7 and Microsoft Deployment Toolkit (MDT) 2010 Update 1.

On the other hand I have a Linux Debian 6 server with a LINBO installation. So there is a running DHCP Server and a TFTP Server with all the images running on that server. In the network there is also a working DNS Server.

Now it should be possible to PXE boot a client and depending on the MAC address in the dhcpd.conf it starts LINBO or WDS.

  1. Is it possible after all?
  2. Does anyone know how to do this?

Thanks in advance!

3 Answers 3

  1. Yes
  2. Yes

    • For MS DHCP Server, open the DHCP MMC, under the relevant scope create a reservation with the apporpriate IP and MAC address, then assign the options under that reservation.
    • For ISC-DHCPd, create a host reservation section under the Scope definitions similar to:

      subnet netmask {
          other options might be here...
          host pxeclient {
              harware ethernet 02:01:03:04:05:06
              next-server pxe.server.example.com
              filename "option 67"

For the WDS server option 066 (next-server) should be the IP of the WDS server; and option 067 (filename) should be "boot\x86\wdsnbp.com". You'll have to figure out the settings for the PXE server, but it should be pretty similar (and already setup and running as I understand the Question).

If your PXE boot *nix clients have NFS roots the option for that is option root-path "nfsserver.example.com:/path/to/rootfs"

  • it seems as if the tftp server rejects the request of the client. I put the filename to "boot\x86\wdsnbp.com" as you said, but on the WDS server it seems to be broken. I also tried "boot\x64\wdsnbp.com" since I'm on a x64 system here's a screenshot of the broken request link PXE errors clientside were PXE-T04 Access Violation, PXE-E36 Error received from TFTP, PXE-M0F exiting. I did not configure anything specific for tftp on the WDS server after installation, do I have to? thanks for your help. Jan 8, 2012 at 20:46
  • I found the solution, it has to be "Boot\x64\wdsnbp.com" so obviously it's case-sensitive. Now I have a new problem, it boots into Lite Touch PE and then gets stuck, just hanging at the screen Microsoft | Solution Accelerators - what irony. Jan 8, 2012 at 22:26

If you'd prefer to select from a menu instead of pre-assigning MAC address, then you can use a pxelinux menu, too.

Set your pxelinux server as the primary boot server, get the pxechain.com module from syslinux, then configure a menu option to forward to the WDS server:

label wds
    menu label WDS
    kernel pxechain.com
    append 10.x.x.x::Boot\x86\wdsnbp.com

Swap in the right IP address and path to wdsnbp.com and you should be all set.

  • thanks for this hint, but the principal wants it that way. do you have a clue why this weird thing is happening? here's the screenshot Jan 8, 2012 at 21:37

I personally found it easier to add the pxelinux binaries and necessary kickstart files to my WDS server. Other than a couple headaches figuring out the paths it has worked well.

My next-server is set to the WDS box, the path to the pxelinux.0 file.

From there I can select to open the Linux installers or my server and workstations builds.

# File: wdspath\RemoteInstall\Boot\x86\pxelinux.cfg\default
# Default boot option to use

DEFAULT menu.c32
# util
LABEL util
MENU LABEL  Utilities
KERNEL menu.c32
APPEND conf/util.conf
# Windows
LABEL Windows
MENU LABEL Windows Remote Installation
KERNEL wdsnbp.0
# Linux x86
MENU LABEL Linux 32bit Installs (x86)
KERNEL menu.c32
APPEND conf/x86.conf
# x64
MENU LABEL Linux 64bit Installs (x64)
KERNEL menu.c32
APPEND conf/x64.conf
# Windows
KERNEL abortpxe.0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .