0

I have a developer environment with two sites configured with anonymous access. Everything was working fine until I migrated to a VM. Now each time I try to enter I get a 401.2 error. I've searched all over the place and tried fixes from various MS knowledgebases but I can't get past the message. If I enable basic authentication it works but I need it to work without authentication.

0

We were having the same issue just now and solved it by brute forcing some settings and for us enabling windows authentication with hard coded credentials (the machine's login) solved the problem. It's not really anonymous like we like it, but client (browser) side you won't be prompted.

  • sounds like fun... will try it – Nicolás Straub Jan 5 '12 at 17:28
  • could you share what you did to get it working? I'm a bit lost on the matter :S – Nicolás Straub Jan 5 '12 at 17:39
0

the problem was that our app was nested inside another app, after changing the virtual location for the app, the problem went away

  • This should be an edit to the original Question. Serverfault isn't a traditional forum, Read our FAQ. serverfault.com/faq – Tom O'Connor Jan 7 '12 at 11:28
  • @TomO'Connor Actually, no. Since this is a resolution to the problem, it is perfectly acceptable for this to be an answer. And after the time limit has passed (48 hours I think) Nicolás can accept it. – sysadmin1138 Jan 7 '12 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.