0

I administer a web server running Debian 5.0.1 on an Amazon EC2 instance and it uses exim4 for sending email. One of the sites on this server sends periodic emails to an email address: mail@domai1.com. A couple of days ago these emails stopped getting through. I changed the email address it was sending to my own email address, mail@mydomain.com and I received it successfully. I then tried to send an email from the command line on the server to each of these addresses. Again, I received the email while the first recipient didn't. I tried other email addresses @domain1.com and they are all failing. After checking the exim4 log I saw the following error message:

SMTP error from remote mail server after RCPT TO:<mail@domain1.com>: host mx01.1and1.co.uk [xxx.xxx.xxx.xxx]: 451 Requested action aborted

I've googled, but I can't seem to find any info on that specific error. Can anyone suggest a way forward for me?

  • Do you own the mailserver for doma1.com? Sounds like whatever mailserver is configured for that domain doesn't work properly, which is why exim can't deliver. It tries, and is basically told 'go away'. – growse Jan 6 '12 at 11:37
0

4XX failures indiciate non permanent failures, your server will be retrying for a few days and then give up. Lacking any clear indication from the receiving side you'll have to wait and see if they fix whatever is wrong. You could email the postmaster address and see if that gets you anywhere.

The remote server could have implemented greylisting, it will give your server a 4XX code and then if your server is standards compliant it will retry upon which the receiving server will eventually accept the email and it will be successfully delivered. It's a pretty effective way to block spam and takes up few resources.

By the way, please use example.com/or/net domains instead of the ones you used, unless you own them. Per http://tools.ietf.org/rfc/rfc2606.txt

i.e. myname@example.org

  • Looks like I'll need to contact the recipient then. Thanks, and also thanks for the heads up about example domain names. Wasn't aware of that. – hellsgate Jan 9 '12 at 12:03
0

My guess is that Domain1.com have configured something to block incoming mail or has a config error. Normally you get additional information at the end of the line stating what.

This error was also quite popular with Gmail for a while and their spam blocking.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.