I have a WDS server setup for use with MDT2010, and everything was working fine until this morning. Now, whenever I try to boot from LAN, I get an error:

Downloaded WDSNBP...

Architecture: x64
WDSNBP started using DHCP Referral.
Contacting Server: (Gateway:
No response from Windows Deployment Services server.
Launching pxeboot.com

My PXE Response Policy setting on the WDS is set to this:

[ ] Do not respond to any client computer
[ ] Respond only to known client computers
[o] Respond to all (known and unknown) client computers
    [X] For unknown clients, notify administrator and respond after approval

The odd thing is that if I clear the approval option (so any computer gets a response) it works fine.

I have delegated permissions on the AD OU to the computer object WDS is running on, but that doesn't seem to have helped.

As it works without approval, I can only assume my DHCP options are fine and this is some sort of AD permission problem.

(Server is Windows Server 2008 SP2)

  • I'm having the same problem except that When the approval option is cleared it doesn't work fine. – Peter Jan 6 '12 at 20:19
  • Same issue here, too. This just started happening today too, after a successful image. No idea what's changed. – TGP1994 Nov 4 '13 at 21:33

With that option ticked, all unkown computers should boot into WDS, but then be listed on the WDS server, awaiting approval, within Pending Devices .

Try extending the PXE response delay settings. It might be failing as the devices are not being approved within WDS, after requesting the boot.


It was mentioned here that you can remove the Mgmt folder in your WDS installation directory, replace it with an empty folder of the same name, and continue on error free.


If you donot want to use WDS and wanna use PXE boot from SCCM instead, then apply option 67 in DHCP as 'smsboot\x64\pxeboot.com' instead of 'smsboot\x64\wdsnp.com'.

Thanks ANoop

  • 1
    Im not sure that "use a completely different, more complex and more expensive tool" is a useful answer. – Cylindric May 27 '16 at 6:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.