I followed these instructions on www.hottonetworking.com to set up VPN on a clean install of Windows Server 2008 SP2 (not R2 yet).

When I then establish a VPN connection to that machine from a client machine (running Windows 7 RC), everything succeeds (it seems since I get a 'Connected' state in the network sharing center window), but I end up with a subnet mask (according to ipconfig /all) of instead of The net effect is that I don't have local network or internet capability.

What additional configuration steps do I have to do to get VPN with the proper subnet mask working?

Update: Using the steps outlined in the Technet article mentioned by Mr. Nimble, I was able to get internet connection. Apparently the subnet mask is not an issue as my coworker was able to connect using his VPN connection and ping the server machine by name as well.


You can configure Routing and Remote Access to either give certain IP, NetMask, and Router information, or you can let it redirect to the DHCP server.

Look at this Technet Article go to the section called "Configure VPN1 to be a VPN server" which is about half way down.

Also make sure the interface (or interfaces) you are using are fully configured for TCP/IP v4 with IPs, Subnet Mask, and a Gateway.

Also see this section on the DHCP relay agent.

  • Thx. I added the certificate as indicated in the Technet article. I also set the range of IP address for clients ( - and indeed I now get internet connection via my server (verified using whatismyipaddress.com). However, the subnet mask is still When opening the Properties dialog for the IPv4 connection on my Windows 7 RC client machine I don't see a way to specify the mask, only the IP address (static or automatic). I suspect there is a setting on the VPN server that needs changing, but I haven't seen anything relevant yet. – Philipp Schmid Jul 2 '09 at 20:36

I've done some testing with the VPN connections on my laptop, and all of them work and are assigned the subnet mask, so I beleive this is the normal and expected setting. As such, this is most likely not the cause of your connectivity issues.

If you are able to access the internet via the VPN connection, then obviously the VPN connection is working and passing traffic correctly. I suspect your issue lies with DNS/name resolution with respect to your intranet.

A simple test would be to try pinging or browsing to the server via IP address - if this works, then you issue is DNS related. The next step would be to ping the fully qualified domain name of the server (instead of 'server', ping 'server.domainname.local', using the correct values for your network of course).

If both those work, then what you'll need to do is set the DNS suffix in your VPN connection properties.

To do this:
- Goto the properties page for the VPN connection in question (on your client PC)
- Click on the networking tab
- Select IPv4 and click the properties button
- Click the Advanced button
- Click the DNS Tab
- On the DNS settings tab, enter your intranet's DNS suffix (the 'domainname.local' from above that matches your network).

Save all those settings, then reconnect to the VPN and trying pinging your server using the short DNS name now - it should hopefully work.

  • Thx, I'll follow up on your suggestions (I'm not connected right now). However, when I was I opened a command window and tried 'ping' the static IP address of the server and it told me that the destination was not reachable (not even timed out). That's why I inferred that my subnet mask was the problem. – Philipp Schmid Jul 2 '09 at 21:13
  • Any chance your subnet is the same on both networks? IE: Your intranet is 192.168.0.x, and the client PC's is the same? I just tried connecting to one of my 2k8 servers from Win7 and with the same subnets, and it connected, but I was getting odd behavior so that may be the cause. – Skawt Jul 2 '09 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.