enter image description herered mark error displayed on remote management to hyper-v hosts

We have a hyper-v host cluster with relatively new hardware. The hosts and the VMs on them all work good, except when I connect to any hyper-v host from another host in the same cluster (remotely using Hyper-V manager), sometimes displays red error (as in attached pic). We see this on different hosts at different times, and is occasional, i.e. it works by its own (nothing to do with any particular time of day or week). This cluster is in DMZ. And this does not seem to affect the working of virtuals or the host. We can connect to the host fine.

We had network guys take a thorough look in to this and they could not find anything. So Network seems OK. We do have few more clusters in non-DMZ zone, and these do not have such problem at all.

Any ideas??

| improve this question | | | | |
  • Are you using NLB on the cluster, as well as Hyper-v? – Mark Jan 17 '12 at 15:22
  • its a failover cluster across Hyper-V hosts, thus virtual machines are highly available. – whizkid Jan 19 '12 at 14:16
  • Apologies for the late update. Resolution: we started the Windows Firewall service on all the hosts and restarted them all, and the error did not come up again. All DNS settings were already correct. (We did start the Firewall service weeks ago, but somehow they were not rebooted for about two months). – whizkid May 2 '12 at 10:30

This thread out on the web may be of some use.


It notes that getting DNS working right is critical. If you are missing DNS suffixes in the network settings or don't have complete DNS information the Hyper-V RPC stuff seems to not look things up right.

  • Since you have a system in a DMZ, make sure the machines point to two DNS servers that both have the servers and the cluster IP exactly correct.
  • Since you have a system in a DMZ, make sure you have full access to all the domain controllers (or get a zoned domain controller in the DMZ and make sure the computers are in that zone).
  • Check the DNS settings on IPv4 for the management interface, in the advanced stuff and make sure the local DMZ domain path is in the search list and configured. Fill out "DNS Suffix for this connection" and check the box that uses it when registering the IP.
  • If you aren't using IPv6, uncheck it in the protocol list so it isn't in play at all. This one in particular helped us with a bunch of weird issues.
  • Check the Security event logs for failed logins and fix broken service passwords.

Before making changes to the management interface network settings (especially if it is shared with other networking types under Hyper-V), you would be well advised to fail all the VMs to other machines on the cluster. Reboot each box after making DNS changes and then check DNS to ensure it updated all the records for itself.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.