I have a basic peer network (WORKGROUP) with PCs connected to sql server 2008 on a Windows 7 machine. I took one XP pc and the server home and connected to the server with no problems. When I plugged them back in at the office, I got the following error with my sql server tcpip odbc connection (sql server login not windows auth):

Microsoft SQL Server Login
Connection failed:
SQLState: '01000'
SQL Server Error: 67
[Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionOpen (Connect()).
Connection failed:
SQLState: '08001'
SQL Server Error: 17
[Microsoft][ODBC SQL Server Driver][DBNETLIB]SQL Server does not exist or access denied.

The next day I took a different client machine running windows 7 and the server home again. The client could login fine but when I plugged them back in at the office I got the same issue. I can ping the server no problems and share files. Same problem with Firewall turned off on all machines. TPC enabled on server port 1433. The two client machines cant log in using SQL server management studio either when they were working fine before.

All other pcs which remained in the office can still connect no problem.

  • Log in via SSMS on the SQL server machine itself, and check the accounts and permissions. – adaptr Jan 11 '12 at 9:31
  • In ssms logins are unchanged. All clients are connecting using the same sqlserver login and pwd – Paul Jan 11 '12 at 10:05
  • faulty client can see the server instance using osql -l – Paul Jan 11 '12 at 10:25
  • error - both clients (the xp and the windows 7 one) are 32bit but the server is 64bit – Paul Jan 11 '12 at 11:12
  • using ms network monitor from client gets 'Icmp: Destination Unreachable Message, Port Unreachable, 81.200.**.**:1434' – Paul Jan 11 '12 at 11:34
  • Allocated the client a static IP in its TCPIPv4 settings identical to its DHCP assigned IP
  • Reserved that address in the netgear router lan ip table
  • ipconfig /release
  • ipconfig /renew
  • Rebooted pc and router now connects via servername
  • Took both home again and back without issue
  • Great to see that you found a solution to your problem. Please come back and put this answer as your accepted one, so that it won't stay open (and get repeatably bumped up). – pauska Jan 14 '12 at 2:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.