0

Simple two-server farm: One SharePoint Foundation 2010 WFE on Windows Server 2008 R2 Std SP1 One SQL Server 2008 Std SP1 backend on Windows Server 2008 SP2

I've just installed Service Pack 1 (14.0.6029.1000) on the SharePoint server and rebooted. Central Administration shows that content databases need upgrading:

Microsoft.SharePoint.Administration.SPContentDatabase Current Schema Version: 14.0.4762.1000, Maximum Schema Version: 14.0.6029.1000

I expected the service pack installation would have done this. I've tried upgrading the databases with the Upgrade-SPContentDatbase powershell cmdlet but receive the message:

WARNING: Database [SPContentDatabase Name=WSS_Content] cannot be upgraded.

What's wrong? Apologies if the answer is obvious to someone else. This is my first SharePoint deployment.

0

2 Answers 2

1

Before trying any of this, take a local backup of your content DB (WSS_Content)

2 suggestions here:

1) Try to perform an inplace build-2-build upgrade with the psconfig tool. Open an elevated command prompt on the WFE and execute: psconfig -cmd upgrade -inplace b2b -wait -force

2) Increment the version number in the Content Database manually. The WSS_Content database has a table called versions. Select the row with the build version (14.0.4762.1000) and update the value to 14.0.6029.1000

Run the Test-SPContentDatabase cmdlet to verify the change.

2
  • Thanks @JudasIscariot1651 I tried the first suggestion before reaslising what I'd missed out. I re-ran SP config wizard which fixed it, but thanks for your time and suggestions. Jan 12, 2012 at 9:50
  • @spartanmouse then you actually did exactly what I suggested, without realising it ;) the Configuration Wizard (psconfigui) employs the exact same mechanism as psconfig -cmd upgrade -inplace b2b -wait -force invokes Jan 12, 2012 at 13:39
1

Newbie error as I feared...

I didn't realise I needed to run the SharePoint Products Configuration Wizard again after installation and reboot. This fixed it right away.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.