I have 3 Windows 2003 servers in a domain. Server 1 is running the AD and VPN roles. Server 2 is running Exchange 2003. Server 3 is running some third party network apps and was supposed to be running the VPN role. They are all in the same subnet

Recently I was running Windows updates on all of them and realized that Server 1 and Server 3 get stuck at "Waiting for response..." in my IE window where the windows updates are running. So after about 5 minutes of waiting windows update gives up and just shows a website not found error. Server 2 meanwhile has no problems downloading updates. The other odd (possibly related) thing is that both Server 1 and Server 3 are unable to access our phone system's web interface which is on a server at IP (note the different subnet). While Server 2 can access the web interface at The reason I think its related is because a few months ago I was trying to setup automatic backup over FTP from the phone system ( to the Server 3, and the FTP connection would mysteriously keep failing. I could never figure out. But once the Windows Update issue happened, I tried setting up the FTP transfer from the phone system to Server 2, and it worked flawlessly. The only difference right now between Server 2 and Server 1/3 is that Server 1/3 have the VPN/RAS role (see number 9 below).

A few things I've tried

  1. Restart both Server 1 and 3.
  2. Disable Windows Firewall.
  3. Disable the Anti Virus program (I'm using Trend Micro).
  4. Check the routing tables on all servers for any conflicts/inconsistencies (using route print/route add/route delete). Again just precautionary, don't think this is the issue because ping (ICMP) and nslookup (DNS) all work fine.
  5. Run a ping test which works fine. Now I can ping from Server 1 and 3 to the phone system ( and microsoft websites. But HTTP still fails. I even tried a raw HTTP test using telnet (and GET request).
  6. Add the microsoft domain and related windows update domains to the list of trusted sites in Internet Options.
  7. Run netdiag on Server 1 and 3. No issues. DNS and DHCP are fine.
  8. Run DNS lookup tests. They are successful.
  9. Remove the VPN/RAS role from both servers 1/3 and attempt windows updates.
  10. Check my router for any specific deny rules.

Any ideas? I was going to run a Wireshark scan, but I really do'nt know what to look for.

Remember I can still surf the web like www.google.com etc from Server 1/3.

  • Just an update. In the Wireshark scan I see that TCP segments are being lost in the replies to the initial GET request. And the reason it does not happen for www.google.com, because the reply is just one big TCP packet. I tested another domain www.reddit.com, did not work either. – Archit Baweja Jan 12 '12 at 18:19

Few suggestions:

  1. Check physical layer (cables, connectors, switch ports)
  2. Check NIC and switch ports speed settings (try forcing 100Mbps full duplex both on switch and on NIC)
  3. Try pinging pingtest.net with different -l option and see if there is difference in dropped packets(for example try with 32, 1000, 1400, 1600, 10000)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.