The majority of my Exchange users are all on Windows 7 and have no issues (at least using Outlook...) but a subset of the executives are ardent Mac users running Outlook 2011 for OS X. One of these clients is prompted every 5-10 minutes for credentials. Ticking the checkbox to remember credentials does not fix the situation.

Mac version is 10.7.2.

I have already removed and rebuilt the EWS virtual directory on my Client Access server.

Outlook anywhere is set to NTLM authentication.

None of the Microsoft clients are experiencing this issue.

What else can I do to make this issue go away?


There may be something off in the way the user's password is being stored in their keychain. Run the Keychain Access utility (from the user's account). If the keychain list isn't shown in the sidebar, choose View menu > Show Keychains. Select the "login" keychain in the sidebar, then run some checks:

  1. Open Keychain First Aid (under the Keychain Access menu), enter the user's account password, select Repair, and click Start. If it finds (& repairs) any problems, check to see if that's solved the problem.
  2. With the login keychain still selected, choose Edit menu > Change Settings for Keychain "login". In the settings dialog, check the autolock settings for the keychain; if it's set to lock after, say, 5 minutes, and Outlook checks for incoming messages every 10 minutes, the keychain will lock between each check. Generally, you want its autolock time to be longer than the email checkin time. (Note: if Outlook caches the password rather than rechecking the password each time, this will not be an issue; I haven't used it, so I don't know.)
  3. If neither of those does the trick, try deleting the relevant keychain entry (/entries), and having Outlook recreate them (with the remember credentials option). Note that starting in OS X 10.9, there's a second user keychain (called either Local Items or iCloud), and you may need to delete entries both there & in the login keychain. It's possible there's something wrong with the entry, or its access policy, or there are multiple conflicting entries; deleting & recreating the entry is generally the simplest way to fix this.
  • Before rebuilding the keychain the user deleted the client profile and tried to start again fresh, but the problem was still occurring. The above fix resolved the issue and it has been three days now since the last popup. Thank you! – Top__Hat Jan 18 '12 at 15:09
  • I have also seen this in the wild as well. When the user is prompted for a password in Outlook 2011, it means the password field in Preferences -> accounts is blank. One may also fix this problem by ensuring the password is there in the password field. – AWippler Jun 23 '14 at 23:28
  • 1
    This covers the specific Keychain items in more detail: answers.microsoft.com/en-us/msoffice/forum/… – Joe Carroll Jan 13 '17 at 8:18

Try to add an additional backslash ("\") in front of your logon domain.

Try to use:


instead of


This triggers a bug (feature) in the MacOS keychain, which leads to persistent credentials.

  • Is there any more information about this "feature"? – Ben L. Apr 27 '16 at 20:00

I had problem with Outlook for Mac - a box kept appearing saying "Authentication Failed - Invalid Credentials" and asking if I wanted to try entering password. If "No" was clicked or if my password was entered, the message would just appear again after a few seconds. Whilst this message was on the screen I could not open Outlook on my MacBook. Solved the problem by clicking Outlook during the few seconds after I had clicked "No" when the message was off the screen. Then clicked Preferences, then Accounts. The password box was empty so I filled it in and the fault message never appeared again and I could open Outlook. Problem solved! Beware that all the operations had to be performed very quickly between clicking "No" which removed the message box for about 5 seconds, before it re-appeared again!


I had this problem of prompting every 5 sec and error of logon failure, tried to reset the keychain but it would not work. So out of despair I simply entered for the login field: login@domain name.com instead of the classic email address or domain\login or login and tadaaa it stopped. So visibly there's a problem for the login field with exchange servers

config: outlook 11, osX, exchange


I work remotely 99% of the time and never had this problem until I came into the corporate office and hopped on their internal WiFi. That's when the problems started for me.

Anyone else notice in the keychain a number of old Exchange password entries? Could that have something to do with it? I decided to purge my system of 7 old entries, leaving only the most recent entry.

Keeping my fingers crossed that fixes the problem. I've tried all other suggestions I could find but no success with any of them.

Cheers, PKD

  • Just an FYI, this is not a forum but a Question and Answer site. Comments such as this should usually be kept to the comments on a question or moved to the chat room for more in depth discussion. That way people looking for answers can find them more easily. – Thomas Apr 26 '17 at 23:31

I changed my account preferences and the problem seems to have gone away,

Server Information user name: xxx@mydomain.com password: mypassword Incoming server: server.mydomain.com Use SSL to connect: check Outgoing Server: server.mydomain.com Port: 465 Override default port Use SSL to connect: check More Options Authentication: Use Incoming Server Info

That seemed to get the passwords to stick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.