I have configured WOL on my Asus E35M-pro. But I have some very weird side affects :

  1. Wake on LAN causes GRUB to have no countdown timer when activated unless I use update-grub
  2. When I shut the machine down, it automatically reboots when WOL is active the only way do shut it down is to force it by holding the power button.

My server is behind a normal switch to which my computer, with whom I issue the magic packet, is attached as well.

Could it be the magic packet remains floating around ?


Could it be the magic packet remains floating around ?

You could find out by running tcpdump on the interface. Usually, there would be nothing "floating around" unless you have a network loop - which in turn would have other nasty symptoms.

I have no idea about why GRUB is behaving differently when waked from LAN. But I have seen some BIOS implementations where any network traffic would trigger a power on - not just the WoL magic packet. Check if you can change your power settings to be "ACPI controlled" in the BIOS setup.

| improve this answer | |
  • There is no option to change the ACPI. And I don't have a network loop. I also tested it by removing the network cable right after issuing the shutdown command and it would still reboot. – Lucas Kauffman Jan 14 '12 at 12:07
  • Then something is probably broken or buggy. Try updating the BIOS to the latest/greatest and if the problem persists, open a call with Asus tech support. – the-wabbit Jan 14 '12 at 14:10
  • Guess Im going to do that last one, because I already updated it to the last one :/ – Lucas Kauffman Jan 14 '12 at 14:16

in the German VDR forum someone found the solution. Turn on either "wake on mouse" or "wake on keyboard" additionally. Sounds strange, but it really helps.

German VDR forum

| improve this answer | |
  • Uh, wow. Nice find. – HopelessN00b Oct 25 '12 at 13:49
  • This is crazy working solution =) I enable wake on lan and wake on keyboard and all is fine. Motherboard Asus p8h61-m – funivan Nov 19 '16 at 17:57
  • What if I have the same problem with a laptop that has no such option in the BIOS? – Ben Apr 5 '19 at 16:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.