I'm having an issue with my ESXi 4.1 hosts losing the datastore with FC SAN after a power outage. All 3 hosts disconnect so it's definitely a SAN issue. I've tried to resolve the issue on the SAN side with the SAN software support and Adaptec hardware support. No luck there.

So I'm stuck with a SAN that will randomly disconnect the volume. I need to get the virtual machines (VMDK files) from the datastore. The problem is I can only get 5-20% before the data store disconnects.

I have backups that are slightly older that I can use to replicate the VMDK differences to.

What has not worked so far:

  1. Powering up the VMs, will boot up for 5-15 minutes then freeze
  2. vCenter migrate or clone of VM, will fail after similar period of time
  3. vCenter copy/paste of VMDK. Was able to get one 30GB VMDK and no luck after that.
  4. vMware Data Recovery. Fails at low %, can't resume, so next backup starts from begining.
  5. Veeam Backup & Recovery. Same as above, no resume function.

If I can just find a backup solution that will resume from the failed spot that would solve my issue. Anyone have any ideas that I could try?


The SAN is Open-E DSS 6 running on a Supermicro 24 drive enclosure with 4 port Qlogic FC. Adaptec 52445 RAID card.

  • what type of san? – tony roth Jan 14 '12 at 20:39
  • The SAN is Open-E DSS 6 running on a Supermicro 24 drive enclosure with 4 port Qlogic FC. Adaptec 52445 RAID card. – Serge Jan 14 '12 at 20:52
  • can't you just connect with something else than your vmware host and try copying the entire datastore volume using dd? – the-wabbit Jan 15 '12 at 0:02
  • syneticon, by "something else"... what do you recommend I connect with? I'm not sure how the result of that would be different than trying to use the 3 ESXi 4.1 hosts that are connected to it now? I need some solution that can resume copying the VMDKs. – Serge Jan 15 '12 at 1:11
  • "something else" as for example a sysrescuecd bootup on one of your hosts. This would be to a) test whether it might be some kind of driver problem or software incompatibility on the ESXi side and b) create a "working" datastore copy which you could attach to one of your ESXi machines so you finally could move your VMDK files. – the-wabbit Jan 15 '12 at 21:32

Its a long shot, but i think vmware converter has an ability to do incramental updates to an export. So you could try kicking off an export, after it fails, try appending the export.

Other than that, my best reccomendation would be to get the SAN vendor in to figure out what's going on.

Secondly, since it's fiber channel (not my best area) are the controller in a redudant configuration? Maybe you simply try one controler or the other if it is.

Edit 1:

Another thought, sort of related. Filezilla I think can continue a failed transfer. Presuming you can SFTP this may be a way to slowly get what you need.

Edit 2:

ESXi = no go for SFTP :( Another thought is, while it may be a bit of work, what if you setup an "ESX" server temporarly just so you can get SFTP access to your VMFS volume? The only reason I'm hung up on SFTP is i'm pretty certain it can restart from a failed transfer, at least via Filezilla.

Edit 3:

Just noticed this is a SW SAN, do you have any 1 gig links that you could maybe try an iSCSI connection? I'm just wondering if it's the fiber channel card in your SAN? Obviously something central about it. Also, do you have more than 1 fiber channel switch? I'm just wondering if you have have something blipping up and down.

  • Thanks for the reply Eric. I forgot to mention that I tried using vmware converter, I did not see any options for incremental backup. Do you have a link to more details about that? – Serge Jan 14 '12 at 20:19
  • I've never used it, but there appears to be a "syncronize" button on the stand alone coverter task – Eric C. Singer Jan 14 '12 at 23:39
  • For stand alone converter task you need to have the machine powered up and install the converter on it. The problem is that powering up the VM will cause the data store to disconnect. – Serge Jan 15 '12 at 1:13
  • Eric, I really appreciate your help. I've already actually tried the SFTP option with ESXi. You can install it by using the support console. I ran into an issue of not being able to copy the files at all with that method (I could connect and see the vmdk though). I was able to find other people with the same problem, but no fix. I'm trying the ESX method now. – Serge Jan 15 '12 at 2:34
  • Did a quick test from my desktop with SFTP using ESX this time, and it looks like it might work. – Serge Jan 15 '12 at 3:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.