I just purchased an HP Microserver I was planning to use with FreeNAS. It needed more RAM, so I tried to follow the instructions to pull out the system board draw to access the DIMM slots. Doing so requires removing all of the cables connected to the board, including a "Mini-SAS" cable. The cable looks like it has an oversized USB-style connector with a metal clip to lock it into place similar to an RJ-45 connector's plastic clip. Try as I might, I couldn't get it to unlock, so I called HP tech support and they had me tug on it a good deal more still to no avail.

I'm thinking maybe the system shipped with a damaged connector, based on the HP video about disconnecting the cable. Has anyone worked with one of these systems? Can you comment on how hard it should be to disconnect that cable?

(Now the system won't start up and HP advised me to do an exchange, which I intend to do, but I found myself wondering if I'd have the same problem with the next unit.)

  • 1
    Actually using a small flat head screwdriver fixed the issue for me
    – tommasop
    Commented Mar 21, 2012 at 11:03
  • In the end I had to pry the top two "claws" at the top edge of the metal "plug" to separate the plug from the black connector with a small flat-headed screwdriver. This was after removing all the cables and snipping the cable ties so I could pull out the tray with the mini-sas connector still attached to get a better look.
    – user115644
    Commented Mar 28, 2012 at 12:32
  • 1
    What I found was that you cant pull the cable up at all before pressing the metal clip, if you do the teeth will hook in to the metal plate and making your life difficult. Hope it helps
    – Balroq
    Commented May 4, 2012 at 10:13
  • 1
    These cables are evil. I used a screwdriver on mine, and swore never to try and take it out again. Commented May 4, 2012 at 10:20
  • @Balroq, you should make your comment an answer so I can upvote you. That was exactly what my issue was. If it is not pressed fully and you start pulling, the connector locks. Commented May 5, 2012 at 5:38

3 Answers 3


I have a number of these servers and it is awkward to disconnect, although it does sound odd you are having this amount of trouble

Tips, because of how the cable is routed and cable tied, also the length of the connector, you need to pull directly up while putting a kink in the actual cable.

The metal clip seems to depress further if you place your finger in the middle. It does latch in to the socket fairly well so getting it depressed far enough is important.

The machine will post without the SAS cable connected so even if you have managed to pull it out slightly, the blue logo should light and the system post. Things that will stop it from booting are having the fan header disconnected (From memory I think that is the cable closest to the SAS connector)

  • 1
    Thanks @chopper3 and Nick Downton. The system is posting again, but I still haven't succeeded with the cable. I'm thinking the metal clip is defective -- when I press on it, the "teeth" that seem to lock the cable in place do not move. It looks like only the top of the clip flexes. I'm a bit puzzled what to do: I got the unit on sale at OnSale.com and they are out of them, so they cannot do an exchange. HP finally is offering to send out an engineer to try to rebuild the system with a new system board and mini-SAS cable, though given that it is brand new, I wish they'd just do an exchange. Commented Jan 16, 2012 at 18:22

I had this problem yesterday (same server, same cable). Here's how I solved the problem:

  1. Insert flathead screwdriver vertically from above into the central tab.

  2. Push outwards until the central tab snaps free.

  3. Insert paper clip horizontally from the side into the space between the cable & the little metal teeth hooked into it.

  4. Twist the paper clip to extract the metal teeth from the cable.

  5. Repeat for the other tooth.

  • 1
    I've had the exact problem as the OP describes -- it is a very painful removal. I'll be honest and say that my inability to remove it is exactly as described - the "key" or "tooth" to keep it locked in from vibration does not retract enough when pushing the obvious release. I had to use my leatherman micro-flathead screwdriver piece to fit into the tooth receptacle to release my mini-sas connector. I thought -- since I'm due to possibly insert a P410 RAID controller card and re-use the mini-SAS cable, I can just break off the release mechanism (which gets rid of the teeth, BTW), and work with
    – user110361
    Commented Feb 12, 2012 at 6:29
  • wow, simpler way of doing it, slide small flat head inbetween the cable head and the metal connector housing. flex the metal housing away until the clip points clear the plastic and pull up.
    – user113295
    Commented Mar 7, 2012 at 22:20
  • 1
    I found aberration's answer most useful. I pulled the connector out by sliding a tiny screwdriver down, vertically, into the metallic connector. There are a couple tiny teeth which prevent you from pulling out the connector. By sliding the screwdriver down I think you can dislodge the teeth. I think it's a mistake to use too much force simply pulling up on the connector.
    – user118272
    Commented Apr 20, 2012 at 16:55

I've dealt with mini-SAS cables/connectors for years now on a range of HP kit and although they're far from the easiest connector to disconnect I've never had the kind of problems you've seen - I'd advise you to do as they say and get it replaced or call in a HP engineer to swap out the cable, motherboard or both.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .