4

Got the following error while trying to add, edit or delete a windows schedule task:

Transaction support within the specified resource manager is not 
started or was shut down due to an error.

Tried to reset transaction manager through fsutil (as suggested by a few people on answers.microsoft.com)

fsutil resource setautoreset true c:\

but it didn't work.

Also noticed that windows update was failing with an unknown error as well.

  • Manually clearing all the files from the following directory fixed the problem C:\Windows\System32\config\TxR I also reset the resource manager through fsutil before restart (not sure it was required or not) fsutil resource setautoreset true c:\ These links were also helpful: support.microsoft.com/kb/2484025 (The link is about fixing windows search service but that occur because of the same problem ) channel9.msdn.com/Forums/TechOff/WindowsUpdate-problem – Faisal Jan 16 '12 at 18:34
  • Good to see you solved your problem! You can add it as an answer below and accept it! – Bart De Vos Jan 17 '12 at 7:52
6

Manually clearing all the files from the following directory fixed the problem

C:\Windows\System32\config\TxR

I also reset the resource manager through fsutil before restart (not sure it was required or not)

fsutil resource setautoreset true c:\

These links were also helpful:

http://support.microsoft.com/kb/2484025 (The link is about fixing windows search service but that occur because of the same problem )

http://channel9.msdn.com/Forums/TechOff/WindowsUpdate-problem

Although I didn't try, but, its possible that the problem occurred because of some stuck NTFS Transaction, so probably you can also try cancelling all the zombie transactions using fsutil

http://technet.microsoft.com/en-us/library/ff621563(WS.10).aspx

First list the transactions using

fsutil transaction list

and then roolback any thing suspicious using

fsutil transaction rollback <GUID>
  • Important to note that the files that need deleting from C:\Windows\System32\config\TxR are hidden OS files. You'll need to go to the file explorer view options, enable 'show hidden files and folders' and also 'show operating system protected files'. You'll then need to reboot. – Rots Oct 11 '17 at 8:12
0

I had the same problem with Windows 8.1 and the only thing that helped me was to do

CHKDSK C:\ /R

And to schedule it to the next reboot.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.