A user is getting the following error when attempting to connect to an Oracle database through an Oracle Forms app. I also get the same error when I try to connect from their computer using sqlplus.

ORA-12514: Message 12514 not found; product=RDBMS73; facility=ORA

There are two Oracle clients on the machine, one for 8 and the other for 10g. The forms runtime is installed in the Oracle 8 client's path. I've set the path to include only Oracle 8 in the path, and the ORACLE_HOME is set to 8's home. The connection details in the tnsnames.ora (both of them) are correct.

When I try tnsping, that returns successfully.

Any ideas?


Your error is: "ORA-12514: TNS:listener does not currently know of service requested in connect descriptor". In practice that means that the client is able to connect the server, but server's listener does not know the SID you are trying to use. You get a different message telling that the client is unable the locate the actual error text.

There are few possibilities for the error:

  1. Most likely the tnsnames.ora contains an error after all. Copy it from some other client where the connection works
  2. The reason may also be that there is some setting in sqlnet.ora that 'guides' the client to behave faulty. Copy that also from a working client (or remove it totally if it is not used elsewhere)
  3. The reason may also be that tnsnames.ora are tried to read from other version's directories. Make sure you have identical tnanames.ora and sqlnet.ora in both versions' ...\network\admin -dir.
  4. A rare change is also that you have TNS_ADMIN set in your registry and it points to somewhere else than than the default ...\network\admin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.