We have a couple of Windows Server 2003 machines on our network and for some reason I can't drag-and-drop files on the desktop or anywhere else.

If I right-click and drag it shows the icon on the cursor, but then when I release it I don't get the right-click menu (ie. copy, paste, etc).

If I left-click and drag a file into a folder I see the file on the cursor but when I release it doesn't move or copy the file.

What's going on here?

  • Did you try the keyboard shortcuts? Can you copy files with another method? Do you get an error message? How do you access the server? Via RDP? Did you check if you have suffient rights? Where the GPOs in you Domain recently updated? Did you recently install some hotfixes? Did you try to restore a previous image of the server and try it? Is it on all servers? – Tom Jan 20 '12 at 11:15

This is the weirdest problem and the weirdest solution. I ran into this same thing today and funny enough simply hitting escape completely fixed it. There's a great thread with a bunch of info and what not here: http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/windows-explorer-not-working-cant-drag-drop/c49da206-ee9d-4bb8-b49e-88864489070f

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.