We have a couple of users with iPhone 4Ss that have been getting email fine up until about 4 or 5 days ago from our Exchange 2003 server.

Email is received fine on their desktops. However, the mail is not getting pushed to their iPhones. Not only is it not getting pushed, but when manually refreshing the email in the phone, it fails with either: "

Cannot get mail. The connection to the server failed


Cannot get mail. Server Error. Contact your server administrator

The error does not always appear. Sometimes it will act as though it has refreshed the mail, but nothing has come through.

Things I have tried:

  • Deleting the accounts on the phones, resetting the phones, re-adding the accounts.
  • Setup the accounts on a separate iPhone 4 and 3GS and still have the same problems. Other users are not experiencing any issues.

While the phones have plenty of free space and the Exchange accounts do not have a cap - I tried archiving (locally to pst) all of the users emails from the server. I then removed the account on the phones, reset and re-added the accounts.

This seems to provide a temporary fix, as email will start downloading again.

But it is only very temporary. By the next day it will have stopped working again with the same errors/symptoms.

I have gone over the server settings several times and everything looks correct.

I am stuck at this point. I cant keep archiving and deleting/re-adding accounts for these couple of users every few days. Mail has worked fine for them for over a year prior to this.

If anyone has any suggestions or ideas on things that I may have overlooked/should try, please let me know.

  • Just to ensure it's not some sort of bizarre outage or certificate error; can you access OWA (webmail) from the safari browser on one of the phones? Also, is this SBS2003 or...? What's your environment? AT&T or Verizon iPhones? – skub Jan 24 '12 at 0:22
  • @skub - remember the OP might not be in the US, in which case there's only one kind of iPhone everywhere else in the world. – Mark Henderson Jan 24 '12 at 0:35

There seems to be a slew of similar problems on the web. The first thing that pops out in my mind is permissions. Specifically, whether or not these users are domain admins of any kind, or members of other special groups.

First thing to do would be to go to https://www.testexchangeconnectivity.com and see what crops up when you use one of the affected accounts. It may help with the troubleshooting.

On Exchange 2010 (yes, I know it's not what you're on) you can't have members of Domain Admins or other Built-in Admins using ActiveSync. There's more information here regarding why specifically, but the quick fix is to check the "allow inheritable permissions" box in the security tab. This will give you a window of an hour to sync the phone. The only reason I mention this fix is that I'm not entirely sure if there was some Windows update that makes Exchange 2003 now behave like Exchange 2010. So take a gander and report back.

Another thing I've seen on the tubes is corrupted email. The fix is to go back to the day that the problem cropped up, and either archive or delete all messages from that day, then resync.

This seems to be a tough one to nail down, with multiple "fixes" for different people. This forum thread on Apple seems to have a majority of the fixes I've found around different sites.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy