I have a Windows 2008 Standard server, fresh install, fully patched with no roles installed.

This morning I went and installed the following roles:

  • AD Certificates
  • Terminal Services
  • IIS

When the server restarts, it goes into "Configuring Updates" for 15 minutes. It then restarts. When it restarts, it says that the updates failed, and rolls them back. When I log in, it brings up the Roles wizard (as it usually does after adding a role) and tells me I need to restart again.

It will not let me remove any roles till I restart. Of course, when I restart it goes back to "Configuring Updates", fails, restarts, rolls back, then demands another restart, repeat and rinse.

How can I remove all of the pending roles without using the Remove Roles task in the Roles screen of the Server Manager (because it won't let me, because it demands a restart)?

2 Answers 2


Try this:

Reboot from the server 2008 install disc and choose the repair option and command prompt.

navigate to c:\windows\winsxs, and rename pending.xml to pending.old


  • Thanks. I managed to get it fixed by another method, but this may have worked too... Jul 2, 2009 at 22:44
  • I had to do this when trying to install a bunch of updates threw the server into a reboot loop. Worked great!
    – a_hardin
    Jun 28, 2010 at 21:54

I was able to fix the issue by:

  • Waiting for the restart loop to finished
  • Log in as a local administrator (not a domain user)
  • Go to the Roles panel, and install each role one-by-one
  • Logging in as local admin each time

Once I had the same roles installed that were failing, it started behaving again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.