I have created a custom role similar to the Virtual Machine Power User (sample) and want to allow the role to export the virtual machines via VMware Converter Standalone but they are receiving "unable to obtain hardware information for the selected machine". A full administrator role does not have the error so I am thinking that there is a permission error.

My custom role has the same permissions outlined in this VMware KB article but the error continues.

  • I think I may have found the issue. VMware Converter permissions need to be assigned at the Data Center level and cannot be assigned at a lower level. Testing continues... – SBWorks Feb 1 '12 at 2:27

I had the similar issue while a converting an Windows 7 VM in VMware standalone vCenter convertor 5.x recently, after did spend time in troubleshooting and finally did this simple thing , I removed the VM from the inventory and re-added again. That's it ! It worked like a charm ! Hope it helps someone !


Right click and run the standalone convertor as Administrator and/or Install the latest version of standalone convertor. The version that worked for me was 6.1.1 build

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.