8

I'm trying to make an iso file which will boot without any key-press from the user. In Windows iso files, when booting from a cd, there is a message "press any key to boot from cd" which will wait for 5-10 seconds and then, if there is no key-press, it will boot from HD.

I searched the web for how to remove this message, and do not press any key and all the answers were "delete bootfix.bin" from the iso.

I edited the iso (I've tried several iso files) to remove the bootfix.bin, but now the iso is not correct.

Do you have any suggestions?

1
  • As Jim B says below, the option to choose what device to boot from is not down to the iso, but the System's BIOS.
    – tombull89
    Jan 26 '12 at 12:15
6

It depends on the BIOS. If it is a traditional PC BIOS then the ISO uses the El Torito boot code (etfsboot.com). In this case deleting \boot\bootfix.bin will work.

If it is an EFI BIOS then the ISO should use EFI boot code (efisys.bin). There is also a efisys_noprompt.bin boot code file that can be used when creating the ISO for EFI systems. Use that file instead if you want to eliminate the prompt.

2

My personal note:

copy "C:\Program Files\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\amd64\Oscdimg\efisys_noprompt.bin" to "fwfile/efisys.bin"

Then make ISO image by makewinpemedia /ISO .... winpe.iso

2
  • This is perfect. Thank you! Jan 9 '20 at 5:16
  • But it would be a good idea to also let people know that you have Windows ADK installed, which is where you've got this from. And you're using an x64 install, mine is C:\Program Files (x86) Jan 9 '20 at 5:17
1

I've always used nlite to make my unattended isos and it has an option to disable that prompt.

1
  • Here is a link to their site if you're interested. nliteos.com
    – SonoIT
    Jan 26 '12 at 17:23
0

That message isn't from windows, that's the PC bios asking which device to boot from when there are multiple bootable devices. You can't remove that without removing the option to boot to the hard drive

EDIT: So technically speaking the message is not in the BIOS. But the message is called by the BIOS via INT 19H. (I mistakeinely thought that it was an in13 message which gets called later) The el torito bootable spec (which is used to emulate one of the boot devices supported by bios) requires that the CD run in emulation or no emulation mode. In order to remove the message you'd have to run a custom no emulation boot loader (eg write your own OS) since none of the devices would be there for an OS to use. See section 5.2 of the bootable cdrom spec. In order to remove the message you would have to remove bootfix.bin entirely. You can't do that because the bios has been told to load it. You could try removing bootfix.bin before creating your ISO.

8
  • you can see this message in bootfix.bin in the iso files. it is related to the iso, not to the BIOS
    – gln
    Jan 26 '12 at 12:13
  • Ok let's say the message does come from whatever bootloader you have (I don't believe so but let's go there). Its still the bios calling that message with whatever interrupt calls it, you can't get rid of it.
    – Jim B
    Jan 26 '12 at 12:21
  • @JimB I'm happy to be proven wrong, but I suspect gln is correct here. I've always thought it was part of the Windows boot image, as I've never seen it on a Linux install/live CD.
    – Bryan
    Jan 26 '12 at 12:51
  • 1
    It is not the BIOS - it is the cd. Basically the cd starts,a nd the program started then asks.
    – TomTom
    Jan 26 '12 at 13:04
  • Then why do you get that when the cd fails to boot? Why is the message always the same? (I'm not saying you are wrong, I'm not sure if that's a cd boot spec but I'm real familar with x86 bios interrupts, and am 100% positive that the bios polls the drives)
    – Jim B
    Jan 26 '12 at 14:21
0

I think BIOS display this message, and BIOS select the boot device. Because when I use a bootable disc, no matter Windows,Linux or FreeDOS disc, my computer always displayed " press any key to boot from an CD".

Sorry, I did a web search. This message isn't come from BIOS, but Bootloader I think.

-1

It's related to the iso and the bootfix.bin. It's a optinaol saftey feature as I understand. To remove it ou should read this article, it could help. I found this: http://technet.microsoft.com/en-us/library/dd744321(WS.10).aspx you should try is out.

Else I will try creating a iso later this night and see if i can get it working. I guess you are trying to make a bootale windows 7 cd right? and just want it to boot when it's in the pc. If you feel like waiting?

4
  • :I'll wait. I need any windows OS boot image. thanks!
    – gln
    Jan 26 '12 at 13:05
  • this article is for efi PCs
    – Jim B
    Jan 26 '12 at 14:23
  • @Jim B yeah sorry! a bit to fast posting that link, I'm gonna post back when i figured out something Jan 26 '12 at 20:56
  • @gln I made it work. What I did was. first. I took a original xp cd, then with nlite - I ripped the files to a folder - opend the folder and removed the bootfix.bin 3. used poweriso to create a image and burn to cd. now I turn on the pc, with the cd ofc, It just runs the install, also, with the unattended feature it can run all the way through with just turning the pc on. Jan 27 '12 at 11:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.