we have a new Windows Server Standard 2008 R2 (no domain, no AD) and I am tring to configure Terminal Services/Remote Desktop connection to allow start just single application and not entire desktop for cerntain users.

I am trying to do it by setting Start the following program on connection (Windows XP)/Start only the following Windows-based application... (Mac OS X Lion) in users RDP file. But it does not work as it worked with Windows 2003 server. And it always shows the entire desktop.

Remote Desktop role is installed on the server, licensing type was not yet selected.

2 Answers 2


You are looking for the RemoteApp feature in Windows Server 2008 R2. It will start a remote desktop session that appears as a single application window.

If your users are meant not to have access to other applications on the terminal server, certain Group Policy settings (including Software Restriction Policies) are necessary. By itself, RemoteApp is not designed to securely limit users to a single application.

  • I tried this. I added desired application to RemoteApp list and generated RDP file there. But it did not help. It again opened full desktop same as if I created RDP file by myself.
    – tssk
    Jan 27, 2012 at 6:57
  • You need to copy the generated RDP file to your client machine and open it there. Please ensure that your clients are running RDC 6.1 or newer. In other words, your minimum client OS requirement is XP SP3, Vista SP1, or Windows 7.
    – Skyhawk
    Jan 27, 2012 at 7:00
  • I did exactly this. But I needed to edit the generated file because I need to conect over different hostname than the one pregenerated. Could this be the problem? I tried from Windows XP SP3 and Mac OS X Lion with Remote Desctop connection 2.1.1.
    – tssk
    Jan 27, 2012 at 7:17
  • Please paste the generated RDP file, including your edits, as a code block in an edit to your original question.
    – Skyhawk
    Jan 27, 2012 at 7:31
  • I tested once more with the generated RDP file for RemoteApp. And it works with Windows XP SP3. But not with Mac OS X (RDP client 2.1.1). Any idea?
    – tssk
    Jan 27, 2012 at 13:15

Without a domain, and group policies, I think you will find this is very difficult.

If you were using group policies, I would suggest you set this policy.

User Configuration/Policies/Administrative Templates/System/Custom User Interface

Without group policy, You could force every session to a particular application by setting the shell in the registry.

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Shell

The option when you are using 2008 R2 or above is to use a RemoteApp, but this does require that your a newer client. I don't believe your OSX client will support RemoteApps.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.