I'm not an expert on DNS matters, but i have configured a few domain before and have a reasonable knowledge of how it's supposed to work.

But this one is over me, I've tried everything to try and identify whether this is a configuration problem, or if it is DNSimple.com having an issue.

A little background, the domain was registered with dns.pt, the main registrar for domains in Portugal, they do not have a DNS service, so when I rented my web server last year I also configured it to be a DNS server.

Long story short, I now moved my email to Google Apps and my web site will soon be migrated to azure, so a web server is no longer needed.

I opted for DNSimple.com because of the API and reasonable pricing for DNS hosting, I changed the name servers to dns simple's supplied ones, ns1.dnsimple.com and ns2, configured the Google Apps service and created a cname record to point www to my old server IP address for the meantime.

Problem is, www.pmcosta.pt does not work, but mail.pmcosta.pt works and goes to Google Apps. This was all done last Friday, way over the set TTL!

How can this be? Why is it not pinging or redirecting to my server? Even though the answer from a nslookup on ns1.dnsimple.com is:

 DNS server handling your query: ns1.dnsimple.com
 DNS server's address:

 Non-authoritative answer:
 www.pmcosta.pt canonical name =

 Authoritative answers can be found from:
 .  nameserver = a.root-servers.net.
 .  nameserver = b.root-servers.net.
 .  nameserver = c.root-servers.net.
 .  nameserver = d.root-servers.net.
 .  nameserver = e.root-servers.net.
 .  nameserver = f.root-servers.net.
 .  nameserver = g.root-servers.net.
 .  nameserver = h.root-servers.net.
 .  nameserver = i.root-servers.net.
 .  nameserver = j.root-servers.net.
 .  nameserver = k.root-servers.net.
 .  nameserver = l.root-servers.net.
 .  nameserver = m.root-servers.net.

DNSimple.com does not report a problem with the domain, and I have other domains in there configure in much the same way, that are working fine.

Could this be because I have still not de-configured DNS hosting on my web server? If so, how would one go about doing it? I'm using the standard windows DNS management, can I just remove the pmcosta.pt node?

Any help with this will be much appreciated.

Kind Regards, P.

  • oh btw, if you can, please clarify what Non-authoritative and authoritative answers mean from the nslookup, that would be great. – Pedro Costa Jan 30 '12 at 12:35

You have set up www.pmcosta.pt as a CNAME to You need to configure it as an A record.

Alternatively, you can set up pmcosta.pt to have an A record pointing to and have www point to pmcosta.pt as a CNAME.


Dig command shows that you are using CNAME to directly link to an IP Address. CNAME should be an alias to A record which in turn points an IP address.

○ ➜ dig www.pmcosta.pt +short

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.