The Windows Update screen comes up and I click on Download Updates. I then get the bar scrolling across the screen and it says Downloading Updates but the counts never increase (0 KB total, 0% complete). I've tried several things found via Google to resolve this but so far nothing has worked.

Quoted from https://serverfault.com/questions/166318/windows-update-not-working-on-windows-2008-r2-standard-x64, except I don't have an unlicensed SQL Server 2008 running. I have also tried several things from Google, including WUInstall and setting up a separate WSUS server and nothing has worked so far.

I've re-registered and sfc'd about every DLL I can think of that might be at all related (a little over 150), I'm not using any proxy servers.

I've downloaded the updates manually, but Windows stalls with a "Searching for updates" that never finishes searching.

Only errors I can find in my log are as follows:

2012-01-30 05:00:10:014  980    f40 AU  WARNING: Failed to change download properties of call, error = 0x80070057
2012-01-30 07:43:06:441  980    fc0 AU  WARNING: Returning due to error from GetDownloadProgressUx, error = 0x8024000C
2012-01-30 07:43:06:443  980    fc0 AU  WARNING: GetInteractiveInstallProgress failed, error = 0x8024000C

Upon googling the first error, I came across some resolution steps:

  1. Click on Start and type services.msc into the search box, then click on services as it appears above. Scroll down the list to Windows Update, right click on it and select stop.

  2. Type this into the search box %windir%\SoftwareDistribution click on "Software Distribution" in the box above and delete the entire contents of the "Download" folder.

  3. Go back and turn the Windows Update service back on.

Which, I've already tried, and no luck.

Later on, it says to download Microsoft's MicrosoftFixit.wu.Run.exe and try that, which I have and no luck. I've also tried Microsoft patch Windows6.1-KB947821-v14-x64.msu which stalls with the ever so annoying "Searching for updates on this computer" forever.

I've tried downloading the third-party FixWU and nothing.

I've tried forcing a reinstall of the Windows Update agent using WindowsUpdateAgent30-x64.exe /wuforce

I've checked the PC for anti-viruses, rootkits, mal-ware, nothing of that sort. I reset all the VPN connections, and turned off the firewall temporarily, still nothing.

I've checked access permissions on C: and it's sub-folders, both built-in Users and Administrators have read/write privileges.

Also tried everything in http://support.microsoft.com/kb/949358, and manually rebuilding/reinstalling the Windows Update agent.

I'm at my wit's end here, not sure what else to do/try, any suggestions???

  • Did you run chkdsk /f?
    – Bigbio2002
    Commented Jan 30, 2012 at 21:17
  • Check proxy settings in IE, turn it off. That works good for me.
    – user210625
    Commented Feb 24, 2014 at 14:01

6 Answers 6


Follow the instructions at the bottom of this KB article to enable extended logging.

Also verify if Background Intelligent Transfer Service (BITS) is running correctly at the machine in question.

Check if BITS download jobs are being created by Windows Update Service running, as administrator:

bitsadmin /list /allusers

Could you post your windowsupdate.log to a place like http://pastebin.com/?

You may also try to stop Windows Update Service (wuauserv) using

sc stop wuauserv

and delete the following folder and registry keys (and sub folders / sub keys):



Delete all BITS jobs related to Windows Update like in the example below

bitsadmin /cancel {4706732F-9E3A-456B-9696-F0D18B8EA327}

Having done that, start wuauserv again:

sc start wuauserv
  • Sorry, nothing worked, finally ended up paying Microsoft support to fix it (ended up taking them 13 hours????) and they didn't even tell me what was wrong in the end, only that "lots of little problems cause big problem" his words exactly. Commented Feb 1, 2012 at 11:28

Since I anyhow do not have permissions to edit @motobói s answer here all I did to get Windows Updates back up working. I did have to do a little bit more/different though.

Stop the following services:

  • Windows Update Service
  • Windows Installer
  • Background Intelligent Transfer Service (BITS)

Delete the following folders contents

  • %windir%\SoftwareDistribution\Datastore
  • %windir%\SoftwareDistribution\Download

Delete registry keys (and sub folders / sub keys):

  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
  • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate

Ensure services are set to start automatically (delayed)

  • Background Intelligent Transfer Service (BITS)
  • Windows Installer
  • Windows Update Service

Restart all services or reboot server

Start windows update and schedule it

Deleting registry results in loss of windows update settings. Start windows update once manually to ensure its working. Set update strategy as you want. (automatically)

Further more maybe try

As for me the steps mentioned above made windows update work again, but collected from the others answers you may'd like to try the following things:

Could you please to follow instructions at the bottom of this KB article and enable extended logging?

Check, too, if BITS download jobs are being created by Windows Update Service running, as administrator and delete all BITS jobs related to Windows Update like in the example below

bitsadmin /list /allusers
bitsadmin /cancel {4706732F-9E3A-456B-9696-F0D18B8EA327}

Try reinstalling Windows Update Agent

WindowsUpdateAgent30-x64.exe /wuforce

thx @motobói and @Brian Deragon for bringing me on the right track


(Probably, would not help the original poster, but may help someone who is directed here by Google). I just ran into a similar issue with Win 7: updates would not arrive, and KB947821 would be "Searching for updates on this computer" forever. Turned out that BITS service for some reason was not running and was set to Manual start. After starting it (and returning it to delayed auto-start), updates seem to work (KB947821 also starts fine, but there was no more reason to run it anyway).


For about the "Searching for updates on this computer" part when installing with locally downloaded update file,I had the similar issue when installing Cumulative update for IE11

I tried to login with the Administrator account and then I can successfully install the downloaded update. Hope this will help someone.


I had this same issue, and none of the suggestions worked for me except I noticed that Windows Update service had a hardware profile called "Unblocked Profile" enabled on the Log On tab, and I disabled it and now Windows Update works.


Load the Windows Desktop Experience for 2008R2, taking all the defaults, load all the various options. Then when completed, reboot the server. After you log in and the Server is done and idle, go to Windows Update and download some updates. You should see the progress bar making progress. I found this is also true on Server 2012R2.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .