1

I have a CentOS 6 server that has curl version 7.19.7. For some reason that doesn't support NTLM authentication. I have found this thread on redhat's site: https://bugzilla.redhat.com/show_bug.cgi?id=603783 and it looks like it should be working on 7.20.1-3.

I'm having a really hard time upgrading curl. I have tried:

yum install curl-7.24.0-1.0.cf.rhel6.x86_64.rpm libcurl-7.24.0-1.0.cf.rhel6.x86_64.rpm libssh2-1.3.0-4.fc17.x86_64.rpm c-ares-1.7.5-2.fc17.x86_64.rpm

However I get:

Error: Package: c-ares-1.7.5-2.fc17.x86_64 (/c-ares-1.7.5-2.fc17.x86_64)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libssh2-1.3.0-4.fc17.x86_64 (/libssh2-1.3.0-4.fc17.x86_64)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: c-ares-1.7.5-2.fc17.x86_64 (/c-ares-1.7.5-2.fc17.x86_64)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I tried adding glibc and then it wants more dependencies and it keeps going. Is there an easier way to do this? I'm afraid if I keep adding more and more something will eventually just break.

This is the thread that I found out about the curl problem - https://bugzilla.redhat.com/show_bug.cgi?id=603783

1 Answer 1

0

Is it possible you're on a 32-bit system, not a 64-bit one?

Try just "yum -y upgrade curl" and paste what happens.

1
  • It's 64 bit. 7.19.7 is the newest in the repo. [root@web2 curl]# yum -y upgrade curl Loaded plugins: fastestmirror, priorities, security Loading mirror speeds from cached hostfile * base: mirror.fdcservers.net * epel: mirror.hmc.edu * extras: mirror.thelinuxfix.com * rpmforge: apt.sw.be * updates: yum.singlehop.com 1151 packages excluded due to repository priority protections Setting up Upgrade Process No Packages marked for Update
    – Keith
    Commented Feb 1, 2012 at 18:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .