4

How do I Increase the log level of Fetchmail?

This seems stupidly easy but I can't find the directive and file I need anywhere on-line.

4

From fetchmail(1) (man 1 fetchmail):

Increasing verbosity of output:

   -v | --verbose
          Verbose mode.  All control messages passed between fetchmail and  the
          mailserver  are echoed to stdout.  Overrides --silent.  Doubling this
          option (-v -v) causes extra diagnostic information to be printed.

About debugging to syslog:

   The  --syslog option (keyword: set syslog) allows you to redirect status and
   error messages emitted to the syslog(3) system daemon  if  available.   Mes-
   sages are logged with an id of fetchmail, the facility LOG_MAIL, and priori-
   ties LOG_ERR, LOG_ALERT or LOG_INFO.  This option is  intended  for  logging
   status  and  error  messages which indicate the status of the daemon and the
   results while fetching mail from the server(s).  Error messages for  command
   line  options and parsing the .fetchmailrc file are still written to stderr,
   or to the specified log file.  The --nosyslog option turns off use  of  sys-
   log(3),  assuming  it’s turned on in the ~/.fetchmailrc file, or that the -L
   or --logfile <file> option was used.

Hope that helps!

  • ooops, I think I forgot to mention that I'm running it as a daemon not from the command line. I'm getting logs in mail.info, but its not detailed enough. – Nick Feb 2 '12 at 19:42
  • Nick, it sounds like the --syslog option is working, but your syslog daemon is only logging high level messages (as expected). How to adjust this varies by what syslogging daemon you use. Can you get the output of ps aux|grep syslog and let me know the name of the process? Could be syslogd rsyslogd or other similiar names. – Kyle Smith Feb 3 '12 at 14:55
  • The process is "syslogd". (/sbin/syslogd) – Nick Feb 3 '12 at 17:09
  • For debugging, you should be able to tack a line into /etc/syslog.conf, like: mail.* /var/log/fetchmail_debug – Kyle Smith Feb 3 '12 at 18:00
  • 1
    The problem being that fetchmail is crap. So, this verbosity setting is ONLY accessible via command-line parameter. I say it's crap as a user for almost 20 years. But it is. Everyone basically agrees. And just today (for this reason, and because verbose is just wrong, it's not fine-grained enough) I'm re-investigating getmail. Which has its latest release a few months ago, fetchmail's latest was 3 years ago... – Jürgen A. Erhard Feb 4 '17 at 15:15
3

at least in Debian you can also run

/etc/init.d/fetchmail debug-run

fetchmail will log directly to console and not fork into background

1

One way to increase verbosity of fetchmail when running it as a daemon is to add '-vv' to the fetchmail init script. For example, in Debian, add '-vv' to the OPTIONS parameter in /etc/init.d/fetchmail, restart fetchmail and then see the verbose output in /var/log/mail.log or /var/log/syslog.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.