2

i am trying to install Gitorious on latest Debian 6.0.4 but i am running into some problems and hope there is somebody out here who might be able to help.

I followed this article: http://gitorious.org/gitorious/pages/DebianSqueezeInstallation
I installed the latest versions of all 3rd party applications like Ruby-Enterprise, Sphinx and ActiveMQ.

Could it have to do with some incompatible versions or "gems" ?

Here is the error when i try to start the daemon:

/etc/init.d/git-daemon start
Starting git-daemon:
/var/www/gitorious/vendor/plugins/ultrasphinx/lib/ultrasphinx/ultrasphinx.rb:201: private method `chomp' called for nil:NilClass (NoMethodError)
from /var/www/gitorious/vendor/rails/activesupport/lib/active_support/dependencies.rb:158:in `require'
from /var/www/gitorious/vendor/rails/activesupport/lib/active_support/dependencies.rb:158:in `require'
from /var/www/gitorious/vendor/plugins/ultrasphinx/lib/ultrasphinx.rb:15 from /var/www/gitorious/vendor/rails/activesupport/lib/active_support/dependencies.rb:158:in `require'
from /var/www/gitorious/vendor/rails/activesupport/lib/active_support/dependencies.rb:158:in `require'
from /var/www/gitorious/vendor/plugins/ultrasphinx/init.rb:2:in `evaluate_init_rb'
from /var/www/gitorious/script/../config/../vendor/rails/railties/lib/rails/plugin.rb:158:in `evaluate_init_rb'
from /var/www/gitorious/vendor/rails/activesupport/lib/active_support/core_ext/kernel/reporting.rb:11:in `silence_warnings'
from /var/www/gitorious/script/../config/../vendor/rails/railties/lib/rails/plugin.rb:154:in `evaluate_init_rb'
from /var/www/gitorious/script/../config/../vendor/rails/railties/lib/rails/plugin.rb:48:in `load'
from /var/www/gitorious/script/../config/../vendor/rails/railties/lib/rails/plugin/loader.rb:38:in `load_plugins'
from /var/www/gitorious/script/../config/../vendor/rails/railties/lib/rails/plugin/loader.rb:37:in `each'
from /var/www/gitorious/script/../config/../vendor/rails/railties/lib/rails/plugin/loader.rb:37:in `load_plugins'
from /var/www/gitorious/script/../config/../vendor/rails/railties/lib/initializer.rb:369:in `load_plugins'
from /var/www/gitorious/script/../config/../vendor/rails/railties/lib/initializer.rb:165:in `process'
from /var/www/gitorious/script/../config/../vendor/rails/railties/lib/initializer.rb:113:in `send'
from /var/www/gitorious/script/../config/../vendor/rails/railties/lib/initializer.rb:113:in `run'
from /var/www/gitorious/script/../config/environment.rb:24
from /opt/ruby-enterprise-1.8.7-2012.01/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `gem_original_require'
from /opt/ruby-enterprise-1.8.7-2012.01/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'
from /var/www/gitorious/script/git-daemon:11 failure

Here is the problem when trying to start sphinx:

/etc/init.d/git-ultrasphinx start
(in /var/www/gitorious)
rake aborted!
private method `chomp' called for nil:NilClass

(See full trace by running task with --trace)

Here is the list of gems:

*** LOCAL GEMS ***

actionmailer (3.2.1)
actionpack (3.2.1)
activemessaging (0.7.1)
activemodel (3.2.1)
activerecord (3.2.1, 2.3.8)
activeresource (3.2.1)
activesupport (3.2.1, 2.3.8)
acts-as-taggable-on (2.0.6)
addressable (2.2.6)
arel (3.0.0)
builder (3.0.0)
bundler (1.0.21)
capillary (1.0.0)
capybara (1.0.1)
childprocess (0.2.1)
chronic (0.3.0)
daemon_controller (0.2.6)
daemons (1.1.0)
diff-lcs (1.1.2)
echoe (4.3.1)
erubis (2.7.0)
eventmachine (0.12.10)
exception_notification (1.0.20090728)
factory_girl (1.3.3)
fastthread (1.0.7)
ffi (1.0.9)
gemcutter (0.6.1)
geoip (0.8.9)
hike (1.2.1)
hodel_3000_compliant_logger (0.1.0)
hoe (2.8.0)
i18n (0.6.0)
journey (1.0.1)
json (1.6.5, 1.5.4)
json_pure (1.5.0)
launchy (2.0.5)
mail (2.4.1)
mime-types (1.17.2, 1.16)
mocha (0.9.10)
multi_json (1.0.4)
mysql (2.8.1)
nokogiri (1.5.0)
oauth (0.4.4)
paperclip (2.2.9.2)
passenger (3.0.11)
polyglot (0.3.3)
proxymachine (1.2.4)
rack (1.4.1, 1.0.1)
rack-cache (1.1)
rack-ssl (1.3.2)
rack-test (0.6.1)
rails (3.2.1)
railties (3.2.1)
rake (0.8.7)
rdiscount (1.3.1.1)
rdoc (3.12)
redis (2.2.0)
redis-namespace (0.7.0)
resque (1.9.8)
revo-ssl_requirement (1.1.0)
riddle (1.2.2)
ruby-hmac (0.4.0)
ruby-net-ldap (0.0.4)
ruby-openid (2.1.8)
ruby-yadis (0.3.4)
rubyforge (2.0.4)
rubygems-update (1.4.2)
rubyzip (0.9.4)
selenium-webdriver (2.4.0)
shoulda (2.9.2)
sinatra (1.0)
sprockets (2.1.2)
state_machine (0.9.4)
stomp (1.1)
SystemTimer (1.2.3)
thor (0.14.6)
tilt (1.3.3)
treetop (1.4.10)
tuxml (0.0.1)
tzinfo (0.3.31)
validates_url_format_of (0.1.1)
vegas (0.1.8)
will_paginate (2.3.15)
xpath (0.1.4)

I really appreciate any help to solve the problem or point me into the right direction.

Thanks in advance! Thomas

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.