I'm currently facing a small problem regarding a new network setup. I have a few desktop PC's and Ethernet printers that all need to be connected via an Ethernet network.

I have 2 routers in the office currently, Router 1 has the ADSL modem built and no wireless and Router 2 is mainly for the wireless connections but there are wired devices connected.

My problem now starts with this: I have a desktop PC plugged into Router 1 along with 2 Laptops via Ethernet with the IP addresses being 192.168.1. and the final Ethernet port connects to the WAN port on the back of Router 2. I have a windows server 2008 R2 plugged into a Router 2 with the IP address of 192.168.2. using 2 of the routers Ethernet ports and 2 printers in the other 2 Ethernet ports.

I'm currently on the server trying to see the other computer on the network but I can only see computers on the 192.168.2. network. The same goes for the desktop PC's - I can only see computers on the 192.168.1. network. If I change the setup of one router to match the 192.168.2 network, but start the IP range at 100 so its would this fix this problem? Or is there something else I could try without having to change IP address's about?

  • what kind of router is router 2?
    – resmon6
    Feb 3, 2012 at 19:03
  • @resmon6 router 2 is a linksys wrt54gl with openwrt installed on it Feb 3, 2012 at 19:11
  • Oh yeah. You should have no problem doing what MikeyB suggested. Just make sure your WLAN and LAN interfaces are bridged. You could even setup openwrt to act as a switch.
    – resmon6
    Feb 3, 2012 at 19:15

3 Answers 3


Flatten out your network so that you only have a single IP space. You probably don't need to have the separation there.

Turn off DHCP on Router 2 and hook it up so that it's acting like a WAP and switch, don't use the WAN port on it. Simplify!

  • Yeah, I'm not sure why there's two routers in one office for no reason Feb 3, 2012 at 19:05
  • If his LAN and WLAN are bridged, he can plug the connection between router 1 and 2 into LAN ports on both routers, then turn off DHCP on router 2. Just make sure to lock down that wireless!
    – resmon6
    Feb 3, 2012 at 19:11

Make sure that there are routes between the two routers and then set up DNS.


I'm afraid you shouldn't use routers for your needs.

You have to tell your computers how to talk accross your routers. Just use the "route add" command.
For example:

Your computer IP is
Your router   IP is
route add -p mask

Your real problems will be:
Do you routers can talk to each other ?
How will you NAT people behind your wireless router ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.