I've been experiencing the oddest thing in RHEL4:

When a new kernel version was released:

  • The upgrade its listed when I do "up2date -l"
  • One week later I tried to upgrade the kernel, but "surprise" the new kernel is not there anymore.

Now I really want to upgrade the kernel and don't know how.

2 Answers 2


About the most usual explanation is that /boot is a separate partition with 'noauto' in /etc/fstab so is not mounted upon boot, when you type 'up2date' then the new kernels will be installed into /boot (which is actually on the / filesystem) and NOT into /boot :)

If this is the case then you may need to;

mount /boot

Then run your update command!

If you paste the output of 'df -h' into your question then someone can update their answer. Perhaps it is also something else which I've not covered! :-)

  • the output of /etc/fstab would be useful as well in this case
    – James
    Jul 4, 2009 at 9:13
  • /dev/sda5 / ext3 defaults 1 1 /dev/sda1 /boot ext3 defaults 1 2 /dev/sda3 /tmp ext3 defaults,noexec 1 0 none /dev/pts devpts gid=5,mode=620 0 0 none /proc proc defaults 0 0 none /dev/shm tmpfs defaults 0 0 /dev/sda2 swap swap defaults 0 0 /dev/hda /media/cdrom auto pamconsole,exec,noauto,managed 0 0
    – criss
    Jul 6, 2009 at 15:41
  • i think the problem is related to the satellite repository.... I been invesigatting , and it looks like up2date is pointing to the wrong server.
    – criss
    Jul 6, 2009 at 15:43

The problem was the satellite repository.

We re-registered, entered a more updated server, and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.