5

I've configured my Windows Server 2008 to allow the remote management (using sconfig). I am connecting (with IP addres) using Windows Server 2008 (full version, where I've configured RSAT) and Server Manager (. I am using administrator account with the password on both systems. Firewalls are off. When I try to use hyper-v role on server i got error: Cannot connect to the RPC service on computer 'xxx.xxx.xxx.xxx'. Make sure your RPC service is running. I chcecked - RPC service is working.

Does anybody know where is the problem?

  • whats the rpc error code? so can you do a "wmic /node:hyperserver-ipaddress os" from the w2k8 server thats configured for rsat? – tony roth Feb 5 '12 at 22:47
3

Believe it or not this is a hostname resolution issue. In a workgroup Hyper-V manager's "Connect to Server..." will NOT take a FQDN (and won't take an IP address) it must be a hostname only.

On the 2008 RSAT server in the hosts file (C:\Windows\System32\drivers\etc) add the IP and hostname of the hyper-v core server and it will work.

Microsoft really should document some of this stuff better.

1

check out this tool http://archive.msdn.microsoft.com/HVRemote

it helps configure authentication between the Hyper-V server and the client computer running RSAT if they are not domain-joined.

0

In addition to the Remote Administration rules, you need to allow access to WMI on the Hyper-V server. Like this:

netsh advfirewall firewall set rule group="windows management instrumentation (wmi)" new enable=yes
  • All firewalls are turned off. Any other ideas? – ŁukaszW.pl Feb 5 '12 at 15:12
  • 1
    Yeah. starting with a -1 for an obviously wrong answer. – TomTom Feb 5 '12 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.