I have a virtual server in the US. When I first set it up I was able to use dynamic port forwarding with

ssh -D PORTNUMBER serveraddress

After that I could set up Firefox to use that as SOCKS5 proxy. I don't know what changed, but for some reason that doesn't work anymore.

Is there a place, where it is set if tunneling is allowed or not? I tried ssh_config file, there was in fact a

Tunnel yes/no

option, but even after switching it to yes and restarting, it didn't change anything.

Where should I look?

EDIT (01:41 GMT+1): The output with -vvv options is rather long, therefore uploaded it to pastebin. I hopefully removed all sensitive data: http://pastebin.com/r4BVC5F1

EDIT (02:13 GMT+1): New output file: http://pastebin.com/VvPVv0ff

I added the "PermitTunnel" option in my config file, now I can log in with -vvv active. However the proxy still won't work. I havent changed on settings on the client side, at least none that I know of. And yes, I 'm using Mac OSX.

EDIT (09:45 GMT+1): Could this have anything to do with messed up hostnames? Or maybe dante or squid configurations intereferring? I seriously don't know, why it's not working anymore...

LAST EDIT: OK, I'm just plainly stupid! Seriously. Everything worked fine. The problem was that I typed in the IP address of my server into the SOCKS server settings. Which can't possibly work. localhost ist of course the right answer. Darn... wasted so much time... Thanks everyone!

  • can you post the result when you add the option -vvv? – Bart De Vos Feb 6 '12 at 0:35
  • updated first post. – cherrun Feb 6 '12 at 0:43
  • Can you connect to other servers? – Bart De Vos Feb 6 '12 at 7:35
  • I can connect other servers over ssh jsut fine. I mean, I can connect to the server in the US as well. Only port forwarding doesn't seem to work... – cherrun Feb 6 '12 at 8:48

There is also an option called PermitTunnel. Make sure this is set to yes. If you can't find it, add it.

In your -vvv-log, it says Exit status 127, this is set by bash when it can not find the command. This could mean it's a client problem. I think you are using OSX, right?

Can you connect to another server? Maybe localhost? Has anything changed to your ssh-client installation? Nothing in .ssh/config?

  • I don't see any "PermitTunnel" option. There is only "PermitLocal...". – cherrun Feb 6 '12 at 0:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.